Your message dated Tue, 19 May 2015 15:35:07 +0000
with message-id <e1yujxv-0005eq...@franck.debian.org>
and subject line Bug#776618: fixed in dactyl 1.2~hg7166-1
has caused the Debian Bug report #776618,
regarding dactyl: please make the build reproducible
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
776618: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776618
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: dactyl
Version: 1.1+hg7904-0+nmu1
Severity: wishlist
Tags: patch
User: reproducible-bui...@lists.alioth.debian.org
Usertags: timestamps
X-Debbugs-Cc: reproducible-bui...@lists.alioth.debian.org

Hi,

While working on the "reproducible builds" effort [1], we have noticed
that dactyl could not be built reproducibly.

The attached patch removes stamps from the build system. Once
applied, dactyl can be built reproducibly in our current experimental
framework.

 [1]: https://wiki.debian.org/ReproducibleBuilds


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-
diff -urNad dactyl.orig/dactyl-1.1+hg7904/debian/rules 
dactyl/dactyl-1.1+hg7904/debian/rules
--- dactyl.orig/dactyl-1.1+hg7904/debian/rules  2015-01-30 00:47:09.317058959 
+0000
+++ dactyl/dactyl-1.1+hg7904/debian/rules       2015-01-30 01:00:16.603764611 
+0000
@@ -3,6 +3,7 @@
 PACKAGES=pentadactyl # teledactyl melodactyl
 VERSION=$(shell dpkg-parsechangelog | \
        sed -n -e '/^Version:/ { s/^Version:\s*//; s/[^a-z0-9]/_/g; p }')
+BUILD_DATE=$(shell date --date="$(shell dpkg-parsechangelog --show-field 
Date)" "+%Y/%m/%d %H:%M:%S")
 
 %:
        dh $@ --with xul-ext
@@ -13,7 +14,7 @@
        dh binary --with xul-ext
 
 override_dh_auto_build:
-       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES='bootstrap.js NEWS' xpi
+       make DIRS=$(PACKAGES) MANGLE=chrome XPI_FILES='bootstrap.js NEWS' 
BUILD_DATE="$(BUILD_DATE)" xpi
 
 override_dh_auto_install:
        for PACKAGE in $(PACKAGES); \

--- End Message ---
--- Begin Message ---
Source: dactyl
Source-Version: 1.2~hg7166-1

We believe that the bug you reported is fixed in the latest version of
dactyl, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 776...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Michael Schutte <mi...@debian.org> (supplier of updated dactyl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 19 May 2015 15:47:49 +0200
Source: dactyl
Binary: xul-ext-pentadactyl
Architecture: source all
Version: 1.2~hg7166-1
Distribution: unstable
Urgency: medium
Maintainer: Mozilla Extension Packaging Team 
<pkg-mozext-maintainers@lists.alioth.debian.org>
Changed-By: Michael Schutte <mi...@debian.org>
Description:
 xul-ext-pentadactyl - Vim-inspired, keyboard-accessible user interface for 
Iceweasel/Fi
Closes: 776618 785300
Changes:
 dactyl (1.2~hg7166-1) unstable; urgency=medium
 .
   * Thank you for the NMU, Don!
   * New upstream revision 7166 from the upstream Mercurial repository at
     <https://code.google.com/p/dactyl/>.
     - Supports Iceweasel/Firefox versions up to 39, closes: #785300.
   * Apply a patch by Chris Lamb to make the build reproducible, closes: 
#776618.
   * Bump Standards-Version to 3.9.6, no changes needed.
Checksums-Sha1:
 54355e85259654fc5d697c05146c4c33d6f624ed 1666 dactyl_1.2~hg7166-1.dsc
 ed4862732495192c9dc4287ce96d7a76d736378e 606755 dactyl_1.2~hg7166.orig.tar.gz
 4153ed4bf3a5d2a28b97514ce1c8cdb94904de75 12056 
dactyl_1.2~hg7166-1.debian.tar.xz
 71f85f8f33c39478b225e025a4aa584c8f2619ec 387212 
xul-ext-pentadactyl_1.2~hg7166-1_all.deb
Checksums-Sha256:
 1e682961689db47dfed3dca28e24d33788b3b25c889f753881df286e32bba935 1666 
dactyl_1.2~hg7166-1.dsc
 90e05dce1a7e201527028ee505fe3f0e042c4e9f6d51258c7956972e8891af17 606755 
dactyl_1.2~hg7166.orig.tar.gz
 a0c3c01cc0a4f45d125a4898cfcc1d39ffbeb8e880ec89046d79e96ad58d42c2 12056 
dactyl_1.2~hg7166-1.debian.tar.xz
 71314ef05a65aa407a25b111a15a4f971c28d7f735247d24d8f57ca5534f2b79 387212 
xul-ext-pentadactyl_1.2~hg7166-1_all.deb
Files:
 1a1f91b4e11c88c8f5f9fbaf0ef26a75 1666 web optional dactyl_1.2~hg7166-1.dsc
 6d80011884c69c3b8fb9078931fd0ef5 606755 web optional 
dactyl_1.2~hg7166.orig.tar.gz
 eab74fd53cd6fb54dc26498cf6aa71a7 12056 web optional 
dactyl_1.2~hg7166-1.debian.tar.xz
 0cafaed5896bde1a467c578bc11c0e36 387212 web optional 
xul-ext-pentadactyl_1.2~hg7166-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQEcBAEBAgAGBQJVWz/gAAoJEPPkEi8djCYaFjQIAIt9WGDfzUzMHzN6FZ/jp2Wn
QEAIGwzgOe+7iX2PM2rh1ewxuIfSMB9wYx+GCx8UBAqll58pMyjnBusH/I789oKB
gX48Z/jfYKcZ8UGRXpah51aRqvw1YDb4mRKuJy5rg4qmDdtobxMDOm7LJ+LWcGZF
Z6BmZRQzm6H/BnAShSi9s4Bfr+fPNV57HRpiZKkwE6yDU0rBNQSX+5DIzpwA0v0j
nOB7C1VkbWWZgA1wuYH84Y0Rt7MaQBYEuoNQSfhhcXZJ/mPHRyOmmOsHN50Yw+ps
RYe0X10arpeCNGesRfz/uuzXYHd6CFbR/Qm74FgE9PVeqGb4AHqS7BVwmYLZ7+g=
=302X
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to