Control: retitle 794627 enigmail fails with pinentry-gnome3 when agent has no 
default DBUS_SESSION_BUS_ADDRESS

On Wed 2015-08-19 13:55:08 +0200, Emmanuel Fleury wrote:
> 
>>  c) while icedove+enigmail is open and failing with gnupg2 and
>>     gnupg-agent 2.1.7 installed, can you open another terminal in the
>>     same session and take the following steps to restart the gpg-agent:
>>
>> gpg-connect-agent killagent /bye
>> gpg-connect-agent /bye
>>
>>     Then go back to enigmail to try to do some secret-key operation
>>     (decrypting a message, sending a signed message)
> 
> Damn, it worked... Seems that restarting the gpg-agent make it work
> again. Let see if it stay like this or disapear at the next start.

Excellent, thanks for your help in debugging this!  It's a bug in
enigmail 1.8.2, that some environment variables aren't being passed
through correctly to gpg (which passes them to gpg-agent, which passes
them to pinentry, whew!)

I think i've fixed it in debian's enigmail package 1.8.2-4, and
forwarded the fix upstream as well.

Could you try it out and let me know if it fixes things for you,
including over the restart that caused it to fail previously?  If it
doesn't fix the situation for you, let me know and we can re-open this
bug.

All the best,

    --dkg

Attachment: signature.asc
Description: PGP signature

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to