Package: mozilla-devscripts
Version: 0.45.1
Severity: normal

Hi,
as of upstream version 45 icedove uses an epoch:

$ rmadison icedove | grep 45
icedove    | 1:45.0~b4-2            | experimental                     | 
source, amd64, armel, i386, mips, mipsel, powerpc, ppc64el, s390x

mozilla-devscripts doesn't take this into account when generating
dependencies. E.g. when a install.rdf has:

   <em:targetApplication>
      <!-- Thunderbird -->
      <Description>
        <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
        <em:minVersion>45.0</em:minVersion>
        <em:maxVersion>46.0</em:maxVersion>
      </Description>
    </em:targetApplication>

it generates

  Breaks: icedove (<< 45.0), thunderbird (<< 45.0)

while it should be

  Breaks: icedove (<< 1:45.0), thunderbird (<< 1:45.0)

Cheers,
 -- Guido


-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'stable-updates'), (500, 'unstable'), 
(500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.5.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages mozilla-devscripts depends on:
ii  perl           5.22.2-1
ii  python         2.7.11-1
ii  python-librdf  1.0.17.1+dfsg-1.2+b3
ii  unzip          6.0-20
ii  zip            3.0-11

mozilla-devscripts recommends no packages.

mozilla-devscripts suggests no packages.

-- no debconf information

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to