Your message dated Tue, 20 Sep 2016 13:10:07 -0400
with message-id <87lgymwl8w....@alice.fifthhorseman.net>
and subject line Re: [Pkg-mozext-maintainers] Bug#703112: #703112 enigmail 
1.4.1-2 not  decrypting mails/verifying sigs with Icedove 10.0.12-1
has caused the Debian Bug report #703112,
regarding enigmail 1.4.1-2 not decrypting mails/verifying sigs with Icedove 
10.0.12-1
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
703112: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=703112
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: enigmail
Version: 2:1.4.1-2
Severity: important

Hi,

I recently moved from i386 to amd64, and since then I can't decrypt/verify
mails with enigmail/icedove.

Debug output is:
2013-03-15 08:18:20.094 [DEBUG] enigmailMessengerOverlay.js: messageFrameUnload
2013-03-15 08:18:20.094 [DEBUG] enigmailMessengerOverlay.js: messageCleanup
2013-03-15 08:18:20.094 [DEBUG] enigmailMessengerOverlay.js: setAttachmentReveal
2013-03-15 08:18:20.094 [DEBUG] enigmailMsgHdrViewOverlay.js: this.messageUnload
2013-03-15 08:18:20.096 [DEBUG] enigmailMsgHdrViewOverlay.js: 
_listener_onStartHeaders
2013-03-15 08:18:20.096 [DEBUG] enigmailCommon.jsm: getFrame: name=messagepane
2013-03-15 08:18:20.096 [DEBUG] enigmailMsgHdrViewOverlay.js: msgFrame=[object 
Window]
2013-03-15 08:18:20.096 [DEBUG] enigmailMsgHdrViewOverlay.js: 
enigmailPrepSecurityInfo
2013-03-15 08:18:20.107 [DEBUG] enigmailMsgHdrViewOverlay.js: 
_listener_onEndHeaders
2013-03-15 08:18:20.112 [DEBUG] enigmailMessengerOverlay.js: messageDecrypt: 
[object Event]
2013-03-15 08:18:20.114 [DEBUG] enigmailCommon.jsm: dispatchEvent f=
2013-03-15 08:18:20.115 [DEBUG] enigmailCommon.jsm: dispatchEvent running 
mainEvent
2013-03-15 08:18:20.115 [DEBUG] enigmailMessengerOverlay.js: messageDecryptCb:
2013-03-15 08:18:20.115 [DEBUG] enigmailMessengerOverlay.js: header 
content-type: multipart/encrypted; boundary="----------=_1363330633-19056-2"; 
protocol="application/pgp-encrypted"
2013-03-15 08:18:20.115 [DEBUG] enigmailMessengerOverlay.js: header 
content-transfer-encoding: 
2013-03-15 08:18:20.115 [DEBUG] enigmailMessengerOverlay.js: header 
x-enigmail-version: 
2013-03-15 08:18:20.115 [DEBUG] enigmailMessengerOverlay.js: header 
x-pgp-encoding-format: 
2013-03-15 08:18:20.115 [DEBUG] enumerateMimeParts:  - multipart/encrypted; 
boundary="----------=_1363330633-19056-2"; protocol="application/pgp-encrypted"
2013-03-15 08:18:20.115 [DEBUG] enumerateMimeParts: 1 - multipart/encrypted; 
boundary="----------=_1363330633-19056-2"; protocol="application/pgp-encrypted"
2013-03-15 08:18:20.115 [DEBUG] enumerateMimeParts: 1.1 - 
application/pgp-encrypted
2013-03-15 08:18:20.115 [DEBUG] enumerateMimeParts: 1.2 - 
application/octet-stream
2013-03-15 08:18:20.115 [DEBUG] enigmailMessengerOverlay.js: embedded objects: 
1.1 / 
2013-03-15 08:18:20.115 [ERROR] enigmailMessengerOverlay.js: messageDecryptCb: 
caught exception: TypeError
Message: 'Cc[NS_ENIGMIMESERVICE_CONTRACTID] is undefined'
File:    
file:///usr/lib/mozilla/extensions/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/%7B847b3a00-7ab1-11d4-8f02-006008948af5%7D/components/enigmail.js
Line:    759
Stack:   
()@file:///usr/lib/mozilla/extensions/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/%7B847b3a00-7ab1-11d4-8f02-006008948af5%7D/components/enigmail.js:759
([object Event],true,[object 
Object])@chrome://enigmail/content/enigmailMessengerOverlay.js:654
([object Array])@chrome://enigmail/content/enigmailMessengerOverlay.js:504
()@resource://enigmail/enigmailCommon.jsm:1207

This looks like bug# 671928, yet the enigmail/icedove versions should be
compatible (enigmail 1.4.1-2, Icedove 10). Reinstalling both packages doesn't
change anything.

Marked "important" because having to save each message and decrypting it on
the command line is rather making enigmail useless ;)

Please advise.

Kind regards,
Robert Waldner



-- System Information:
Debian Release: 7.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'testing-proposed-updates'), (500, 
'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.8-trunk-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.ISO-8859-15, LC_CTYPE=en_US.ISO-8859-15 (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/dash

Versions of packages enigmail depends on:
ii  gnupg        1.4.12-7
ii  iceape       2.7.12-1
ii  icedove      10.0.12-1
ii  libc6        2.13-38
ii  libgcc1      1:4.7.2-5
ii  libnspr4-0d  2:4.9.5-1
ii  libstdc++6   4.7.2-5

enigmail recommends no packages.

enigmail suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
On Sun 2016-09-18 17:23:35 -0400, Robert Waldner wrote:
> Hi Alexander,
>
> On Thu, 08 Sep 2016 23:40:11 +0200, Alexander Sack writes:
>>sorry for ping on this old bug and for not getting earlier to you. Is
>>this issue still something that should be looked into?
>
> for me the problem was solved after creating some symlinks, see #110
>  (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=703112#110). A 
>  similar problem hasn't resurfaced since.

fwiw, this was only relevant when enigmail had binary components on a
multi-arch system.  Modern enigmail is architecture-independent
(javascript only), so i think this bug can be closed.

            --dkg

--- End Message ---
_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to