Your message dated Sat, 05 Aug 2017 19:50:02 +0000
with message-id <e1de55g-00060t...@fasolo.debian.org>
and subject line Bug#794627: fixed in enigmail 2:1.9.8.1-1~deb8u1
has caused the Debian Bug report #794627,
regarding Upgrade to gpg2.1 breaks enigmail
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
794627: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=794627
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: gnupg2
Version: 2.1.7-2
Severity: important

Hi,

since the upgrade from gpg 2.0 to 2.1, enigmail no longer works
properly. I use enigmail 1.8.2 which defaults to /usr/bin/gpg2.

It no longer asks me to unlock my key when trying to sign emails but
simply fails.

I use GNOME and pinentry-gnome3.

Using gpg2 directly on the command line works fine and I get a proper
GNOME3 pinentry dialog.

Is there a way to get a log from enigmail somehow to have a better clue
what is failing?

Michael


-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (200, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.1.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gnupg2 depends on:
ii  dpkg           1.18.2
ii  gnupg-agent    2.1.7-2
ii  install-info   6.0.0.dfsg.1-3
ii  libassuan0     2.2.1-1
ii  libbz2-1.0     1.0.6-8
ii  libc6          2.19-19
ii  libgcrypt20    1.6.3-2
ii  libgpg-error0  1.19-2
ii  libksba8       1.3.3-1
ii  libreadline6   6.3-8+b3
ii  zlib1g         1:1.2.8.dfsg-2+b1

Versions of packages gnupg2 recommends:
ii  dirmngr  2.1.7-2

Versions of packages gnupg2 suggests:
pn  gnupg-doc   <none>
pn  parcimonie  <none>
pn  xloadimage  <none>

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: enigmail
Source-Version: 2:1.9.8.1-1~deb8u1

We believe that the bug you reported is fixed in the latest version of
enigmail, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 794...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Kahn Gillmor <d...@fifthhorseman.net> (supplier of updated enigmail 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Thu, 27 Jul 2017 10:17:26 -0400
Source: enigmail
Binary: enigmail
Architecture: source all
Version: 2:1.9.8.1-1~deb8u1
Distribution: jessie-security
Urgency: medium
Maintainer: Debian Mozilla Extension Maintainers 
<pkg-mozext-maintainers@lists.alioth.debian.org>
Changed-By: Daniel Kahn Gillmor <d...@fifthhorseman.net>
Description:
 enigmail   - GPG support for Thunderbird and Debian Icedove
Closes: 794627 842212 863273 869774
Changes:
 enigmail (2:1.9.8.1-1~deb8u1) jessie-security; urgency=medium
 .
   * Rebuild for jessie-security (Closes: #869774)
 .
 enigmail (2:1.9.8.1-1) unstable; urgency=medium
 .
   * new upstream release
 .
 enigmail (2:1.9.8-1) unstable; urgency=medium
 .
   * New upstream release.
   * Standards-Version to 4.0.0 (no changes needed)
   * use dpkg/pkg-info.mk instead of dpkg-parsechangelog
   * use wrap-and-sort -ast
 .
 enigmail (2:1.9.7-2) unstable; urgency=medium
 .
   * enable re-certifying keys with expired certs (Closes: #863273)
 .
 enigmail (2:1.9.7-1) unstable; urgency=medium
 .
   * new upstream bugfix release
 .
 enigmail (2:1.9.6-2) unstable; urgency=medium
 .
   * pulled a bugfix from upstream, refreshed patches
 .
 enigmail (2:1.9.6-1) unstable; urgency=medium
 .
   * new upstream release
 .
 enigmail (2:1.9.5-7) unstable; urgency=medium
 .
   * fix "exchange repair" variant format of e-mail
 .
 enigmail (2:1.9.5-6) unstable; urgency=medium
 .
   * refresh patches from upstream enigmail-1.9-branch
 .
 enigmail (2:1.9.5-5) unstable; urgency=medium
 .
   * fix query for getKeyFileType (Closes: #842212)
 .
 enigmail (2:1.9.5-4) unstable; urgency=medium
 .
   * avoid parallel build failures
 .
 enigmail (2:1.9.5-3) unstable; urgency=medium
 .
   * more patches from upstream
   * bump to debhelper 10 (no changes needed)
 .
 enigmail (2:1.9.5-2) unstable; urgency=medium
 .
   * include two patches from upstream
 .
 enigmail (2:1.9.5-1) unstable; urgency=medium
 .
   * new upstream release
 .
 enigmail (2:1.9.4-1) unstable; urgency=medium
 .
   * new upstream release
 .
 enigmail (2:1.9.3-2) unstable; urgency=medium
 .
   * pulled more fixes from upstream
 .
 enigmail (2:1.9.3-1) unstable; urgency=medium
 .
   * new upstream release
 .
 enigmail (2:1.9.2-1) unstable; urgency=medium
 .
   * new upstream release
   * drop old upstream patches, pull more fixes from upstream
 .
 enigmail (2:1.9.1-2) unstable; urgency=medium
 .
   * changed dependencies to acknowledge newer versions of gnupg.
   * bumped Standards-Version to 3.9.8 (no changes needed)
 .
 enigmail (2:1.9.1-1) unstable; urgency=medium
 .
   * new upstream release
   * incorporated some additional minor patches from upstream's
     enigmial-1.9-branch as well.
 .
 enigmail (2:1.9-1) unstable; urgency=medium
 .
   * new upstream release
   * include upstream fix for excessive dumping
   * bumped Standards-Version to 3.9.7 (no changes needed)
 .
 enigmail (2:1.9~beta2+16.gd99b-1) experimental; urgency=medium
 .
   * new upstream snapshot
 .
 enigmail (2:1.9~beta2-1) experimental; urgency=medium
 .
   * new upstream beta release.
   * depend directly on gnupg2 -- 1.9 and later won't work with gpg1.
 .
 enigmail (2:1.9~beta1-1) experimental; urgency=medium
 .
   * package new upstream beta for experimental.
 .
 enigmail (2:1.8.2-4) unstable; urgency=medium
 .
   * pass through {GTK,QT}_IM_MODULE, XMODIFIERS, and
     DBUS_SESSION_BUS_ADDRESS so that modern pinentry works. (Closes: #794627)
   * correct reported version number of enigmail
Checksums-Sha1:
 64d9d63a943ca9dfb2dbfd661c260ac288788ec9 2119 enigmail_1.9.8.1-1~deb8u1.dsc
 c2a08c14ea548cfa3893f014653ecdca4501669f 1776673 enigmail_1.9.8.1.orig.tar.gz
 219859b753d3611adf1b23a136ed7d6791d7a740 28756 
enigmail_1.9.8.1-1~deb8u1.debian.tar.xz
 cb1c319d6c5ece65ed41e0b4aeca057fb46c7d85 966242 
enigmail_1.9.8.1-1~deb8u1_all.deb
Checksums-Sha256:
 9109a17845130684fd96751955249bf4af26a9d54af0bedb81ccf155c5c8d50e 2119 
enigmail_1.9.8.1-1~deb8u1.dsc
 4bcf2da00d96a67921b24dbec9f43930cba41112a2cd241b0952eb573c648a4d 1776673 
enigmail_1.9.8.1.orig.tar.gz
 8105f833b72393724d89621d8d607fbe9fe0420e8f8c891621e44cef33dc980c 28756 
enigmail_1.9.8.1-1~deb8u1.debian.tar.xz
 9b5248195ff26cf3fe745a1fbde9caf45cf2f3939049e6b1668f6378cc1ff2d5 966242 
enigmail_1.9.8.1-1~deb8u1_all.deb
Files:
 4f9e5c6619bd50eabb76af4b7b1a5613 2119 mail optional 
enigmail_1.9.8.1-1~deb8u1.dsc
 b1da87d6a16d3b4f5b5f58ce3a98eafe 1776673 mail optional 
enigmail_1.9.8.1.orig.tar.gz
 33bfa17171d14c1df22fbd1b52700a43 28756 mail optional 
enigmail_1.9.8.1-1~deb8u1.debian.tar.xz
 e8fc87de10d61732cd574a42989fffe3 966242 mail optional 
enigmail_1.9.8.1-1~deb8u1_all.deb

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEOCdgUepHf6PklTkyFJitxsGSMjcFAll6cD8ACgkQFJitxsGS
MjdA+A//fuOy/5HQ4W47tVVQFZ66Pr0PEjLj2//lxZXoMVOzKLpwvpzZH8YaWCZp
ClkMVr78qED9mq/c/3cz2vfAi2v9JyZ9Et7yUrmjm8SQA3SvKY4W3LBPZ5EOwf+s
3HeXXZcBsEJw8PedwuoJ6rnXk+5ZqX/md7hX8YzbvaehQI/6a5L5cUK6Eg2f0hYb
u8CO6+5PVLLKNKxj8a00OHHGdN1AzbAYijUT7qg6z0qBKtDKD9esopCs6Fsiw9kt
kXQ3CZWDhLx0hxDwntkJkhdbBHvFNUVZmLDqRCBmVGE5h6Fx1YDv3NfGHppTg+A9
lynZaUqVqQpPGkfqj13oIcbGyKgHiBDgKfkbkmbgA4MclmjhC0ada/ixMTC+i35I
sc3lyDW3YAibj5H25k+p2iI5nN1uVsbu2/4b4zU6y7Y0Gu5kJGGe/AtUwzl6/KyK
FZRDPQCbyRlNh/aCD20Abg7TVxHDKSU1TYiDiTTE6L/WXfDeDw5iY39MlME13aTS
rjFCLw0lnDwklKU/277bPtwRh2ttMAp0ly+DHB17ihMtWvO+kPxJcVkgQo9iCWkP
8RJMilz7gItL40k7rNGmiXdULgjjnQA7WmQR3b2qA+F1O2sn1Fx5fTHnRsbn3iEC
JFaZbfSMwLfZZe3giJY3O0ktpuFdMtagz8teX9skGc9SQGmYQJA=
=KgVC
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to