Your message dated Sat, 7 Oct 2017 14:51:42 +0200
with message-id <20171007125139.knuptijgl4fb4...@i5.cruise.homelinux.net>
and subject line Re: Bug#870073: [Pkg-mozext-maintainers] Bug#870073: 
gnome-keyring hijacking gpg-agent on jessie
has caused the Debian Bug report #870073,
regarding gnome-keyring hijacks gpg-agent on jessie
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
870073: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870073
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: enigmail
Version: 2:1.9.8.1-1~deb8u1
Severity: important

Dear Maintainer,

After the security upgrade to Thunderbird version 52.2.1 Enigmail did not work
anymore. I've tried now Enigmail version 2:1.9.8.1-1~deb8u1 but it has the same
problem.  Because I could not install this version of Enigmail using apt, I've
downloaded it from here:
http://security.debian.org/debian-
security/pool/updates/main/e/enigmail/enigmail_1.9.8.1-1~deb8u1_all.deb
And installed it with "dpkg -i".

When I read an encrypted message in Thunderbird, I get this warning:
------
Enigmail Alert:
GnuPG reported an error in the communication with gpg-agent (a component of
GnuPG).
This is a system setup or configuration error that prevents Enigmail from
working properly and cannot be fixed automatically.
We strongly recommend that you consult our support web site at
https://enigmail.net/faq.
------
After this, the message is decrypted.

But when I sent a message to somebody with a PGP key in my keyring, the message
is normally encrypted. But not now, and I do not get a warning about that.

With Thunderbird 45 I did not have these problems.

With regards,
Paul van der Vlis



-- System Information:
Debian Release: 8.9
  APT prefers oldstable-updates
  APT policy: (500, 'oldstable-updates'), (500, 'oldstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-0.bpo.3-amd64 (SMP w/2 CPU cores)
Locale: LANG=nl_NL.utf8, LC_CTYPE=nl_NL.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages enigmail depends on:
ii  gnupg                  1.4.18-7+deb8u3
ii  gnupg-agent            2.0.26-6+deb8u1
ii  gnupg2                 2.0.26-6+deb8u1
ii  icedove                1:52.2.1-4~deb8u1
ii  thunderbird [icedove]  1:52.2.1-4~deb8u1

Versions of packages enigmail recommends:
ii  pinentry-gtk2 [pinentry-x11]  0.8.3-2

enigmail suggests no packages.

--- End Message ---
--- Begin Message ---
Version: 1:52.3.0-4~deb8u2

Hi *,

On Mon, Aug 07, 2017 at 06:57:14PM -0400, Daniel Kahn Gillmor wrote:
... 
> I think maybe the other report that you're making here is that the
> checkboxes on thunderbird 53 menus on jessie are not visible.
> 
> I can confirm that:
> 

> 
> I've cloned this bug to document that problem and bring it to the
> attention of the thunderbird devs.

this issue was related to some regression that got introduced by the
switch to GTK+3 within the build configuration which got taken back in
preparation for version 52.3.0-4~deb8u1.
It would be better if someone would dig into the root of the problem, I
haven't the time nor the knowledge to figure out what's going wrong
inside Thunderbird with the enabled cairo toolset of GTK+2. Caculating
and assuming GTK+2 will supported longer than a LTS time of Jessie we
decided to just switch back to GTK+2 for Jessie security updates
of Thunderbird.

Regards
Carsten

--- End Message ---
_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to