"B. Bogart" <b...@ekran.org> writes:

> Reinhard Tartler wrote:
>> this is a good indication that this bug is also present in current
>> trunk, i.e., this bug needs to be confirmed and upstreamed.
>
> Compiling ffmpeg fresh for current svn also has the same problem.

okay, then this bug definitly upstreaming.

see http://ffmpeg.org/bugreports.html for details, much appreciated if
you could help us out here.

>> Just a try: please disable your /usr/lib/i686/cmov/ directory (e.g.,
>> by renaming). If this causes the symptom to disappear, then the
>> defect is in the hand written assembler in i386/dsputil_mmx.c
>
> renaming the directory has not changed the result:
>
> Program received signal SIGSEGV, Segmentation fault.
> [Switching to Thread 0xf73776c0 (LWP 19789)]
> 0xf79c77b0 in get_pixels_mmx (block=0x85fdbf0, pixels=0x0, line_size=336)
>     at
> /build/siretart-ffmpeg-debian_0.svn20080206-18-i386-ZyxKlX/ffmpeg-debian-0.svn20080206-18/libavcodec/i386/dsputil_mmx.c:225
> 225

Hm, do we really enable mmx in the non-optimized build? I wonder if that
is a clever idea, but this would be a seperate bug anyways.

Since you already have confirmed this bug in current trunk, would you
mind to check if the symptom disappears if you run ./configure without
mmx, e.g., add the configure switch --disable-mmx?

-- 
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4



_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to