Package: ardour-i686
Version: 1:2.8.4-2
Severity: grave

the last time I used ardour two days ago. I believe it was
1:2.8.4-1 - today after updating to 1:2.8.4-2 I can no longer
launch the application. A downgrade does not help. Maybe its
because a file changed that ardour uses but that is in another
package.

Below valgrind output shows an invalid memory access while
loading lv2 plugins. I am not aware that debian ships any of
those though or that such plugins are installed on this
system here.

Hopefully somebody can make use of below information: I setup
the script that loads ardour to valgrind it. the limit should
not matter, does it?

#############
WARNING: Your system has a limit for maximum amount of locked memory!
         This might cause Ardour to run out of memory before your system runs
         out of memory. You can view the memory limit with 'ulimit -l', and it
         is normally controlled by /etc/security/limits.conf

==29391== Memcheck, a memory error detector
==29391== Copyright (C) 2002-2009, and GNU GPL'd, by Julian Seward et al.
==29391== Using Valgrind-3.5.0-Debian and LibVEX; rerun with -h for copyright 
info
==29391== Command: /usr/lib/ardour2/ardour-2.8.4
==29391== 
Ardour/GTK 2.8.4
   (built using 6077 and GCC version 4.4.2)
Copyright (C) 1999-2008 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

Ardour comes with ABSOLUTELY NO WARRANTY
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
This is free software, and you are welcome to redistribute it 
under certain conditions; see the source for copying conditions.
loading default ui configuration file /etc/ardour2/ardour2_ui_default.conf
loading user ui configuration file /home/dub/.ardour2/ardour2_ui.conf
Loading ui configuration file /etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour will be limited to 1014 open files
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/dub/.ardour2/ardour.rc
ardour: [INFO]: No H/W specific optimizations in use
==29391== Jump to the invalid address stated on the next line
==29391==    at 0xC: ???
==29391==    by 0x58CEF8F: rasqal_engine_execute_init (in 
/usr/lib/librasqal.so.1.0.0)
==29391==    by 0x58CA128: rasqal_query_execute (in /usr/lib/librasqal.so.1.0.0)
==29391==    by 0x58A8781: ??? (in /usr/lib/librdf.so.0.0.0)
==29391==    by 0x58A5D49: librdf_query_execute (in /usr/lib/librdf.so.0.0.0)
==29391==    by 0x595A83D: slv2_world_load_specifications (in 
/usr/lib/libslv2.so.9.2.0)
==29391==    by 0x595AE93: slv2_world_load_all (in /usr/lib/libslv2.so.9.2.0)
==29391==    by 0x424E262: ARDOUR::LV2World::LV2World() (in 
/usr/lib/ardour2/libardour.so)
==29391==    by 0x4198453: ARDOUR::PluginManager::PluginManager() (in 
/usr/lib/ardour2/libardour.so)
==29391==    by 0x41462D0: ARDOUR::init(bool, bool) (in 
/usr/lib/ardour2/libardour.so)
==29391==    by 0x816080C: ARDOUR_UI::ARDOUR_UI(int*, char***) (in 
/usr/lib/ardour2/ardour-2.8.4)
==29391==  Address 0xc is not stack'd, malloc'd or (recently) free'd
==29391== 
==29391== 
==29391== Process terminating with default action of signal 11 (SIGSEGV)
==29391==  Bad permissions for mapped region at address 0xC
==29391==    at 0xC: ???
==29391==    by 0x58CEF8F: rasqal_engine_execute_init (in 
/usr/lib/librasqal.so.1.0.0)
==29391==    by 0x58CA128: rasqal_query_execute (in /usr/lib/librasqal.so.1.0.0)
==29391==    by 0x58A8781: ??? (in /usr/lib/librdf.so.0.0.0)
==29391==    by 0x58A5D49: librdf_query_execute (in /usr/lib/librdf.so.0.0.0)
==29391==    by 0x595A83D: slv2_world_load_specifications (in 
/usr/lib/libslv2.so.9.2.0)
==29391==    by 0x595AE93: slv2_world_load_all (in /usr/lib/libslv2.so.9.2.0)
==29391==    by 0x424E262: ARDOUR::LV2World::LV2World() (in 
/usr/lib/ardour2/libardour.so)
==29391==    by 0x4198453: ARDOUR::PluginManager::PluginManager() (in 
/usr/lib/ardour2/libardour.so)
==29391==    by 0x41462D0: ARDOUR::init(bool, bool) (in 
/usr/lib/ardour2/libardour.so)
==29391==    by 0x816080C: ARDOUR_UI::ARDOUR_UI(int*, char***) (in 
/usr/lib/ardour2/ardour-2.8.4)
==29391== 
==29391== HEAP SUMMARY:
==29391==     in use at exit: 2,469,368 bytes in 57,769 blocks
==29391==   total heap usage: 233,153 allocs, 175,384 frees, 10,941,411 bytes 
allocated
==29391== 
==29391== LEAK SUMMARY:
==29391==    definitely lost: 3,583 bytes in 24 blocks
==29391==    indirectly lost: 10,200 bytes in 522 blocks
==29391==      possibly lost: 686,605 bytes in 11,538 blocks
==29391==    still reachable: 1,768,980 bytes in 45,685 blocks
==29391==         suppressed: 0 bytes in 0 blocks
==29391== Rerun with --leak-check=full to see details of leaked memory
==29391== 
==29391== For counts of detected and suppressed errors, rerun with: -v
==29391== ERROR SUMMARY: 1 errors from 1 contexts (suppressed: 244 from 11)
Killed 
#############



-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.31-1-686 (SMP w/1 CPU core)
Locale: LANG=de_AT.UTF-8, LC_CTYPE=de_AT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages ardour-i686 depends on:
ii  jackd                    0.118+svn3796-1 JACK Audio Connection Kit (server 
ii  libart-2.0-2             2.3.20-2        Library of functions for 2D graphi
ii  libasound2               1.0.21a-1       shared library for ALSA applicatio
ii  libatk1.0-0              1.28.0-1        The ATK accessibility toolkit
ii  libaubio2                0.3.2-4         a library for audio segmentation
ii  libc6                    2.10.2-2        GNU C Library: Shared libraries
ii  libcairo2                1.8.8-2         The Cairo 2D vector graphics libra
ii  libcairomm-1.0-1         1.8.0-1         C++ wrappers for Cairo (shared lib
ii  libcurl3-gnutls          7.19.7-1        Multi-protocol file transfer libra
ii  libfftw3-3               3.2.2-1         library for computing Fast Fourier
ii  libfontconfig1           2.6.0-4.2       generic font configuration library
ii  libfreetype6             2.3.11-1        FreeType 2 font engine, shared lib
ii  libgcc1                  1:4.4.2-5       GCC support library
ii  libglib2.0-0             2.22.3-1        The GLib library of C routines
ii  libglibmm-2.4-1c2a       2.22.1-2        C++ wrapper for the GLib toolkit (
ii  libgnomecanvas2-0        2.26.0-1        A powerful object-oriented display
ii  libgnomecanvasmm-2.6-1c2 2.26.0-1        C++ wrappers for libgnomecanvas2 (
ii  libgtk2.0-0              2.18.5-1        The GTK+ graphical user interface 
ii  libgtkmm-2.4-1c2a        1:2.18.2-1      C++ wrappers for GTK+ 2.4 (shared 
ii  libjack0                 0.118+svn3796-1 JACK Audio Connection Kit (librari
ii  liblo0ldbl               0.23-2.2        Lightweight OSC library
ii  liblrdf0                 0.4.0-1.2       a library to manipulate RDF files 
ii  libpango1.0-0            1.26.2-1        Layout and rendering of internatio
ii  libpangomm-1.4-1         2.26.0-1        C++ Wrapper for pango (shared libr
ii  libraptor1               1.4.20-1        Raptor RDF parser and serializer l
ii  librasqal1               0.9.16-2        Rasqal RDF query library
ii  librdf0                  1.0.10-1        Redland Resource Description Frame
ii  libsamplerate0           0.1.7-3         Audio sample rate conversion libra
ii  libsigc++-2.0-0c2a       2.0.18-2        type-safe Signal Framework for C++
ii  libslv2-9                0.6.6-2         A library for simple use of LV2 pl
ii  libsndfile1              1.0.21-2        Library for reading/writing audio 
ii  libstdc++6               4.4.2-5         The GNU Standard C++ Library v3
ii  libusb-0.1-4             2:0.1.12-13     userspace USB programming library
ii  libvamp-hostsdk2         1.3-1           helper library for Vamp hosts writ
ii  libvamp-sdk1             1.3-1           helper library for Vamp plugins wr
ii  libxml2                  2.7.6.dfsg-1    GNOME XML library
ii  libxslt1.1               1.1.26-1        XSLT processing library - runtime 
ii  python                   2.5.4-4         An interactive high-level object-o
ii  python-gtk2              2.16.0-1        Python bindings for the GTK+ widge
ii  python-twisted           8.2.0-3         Event-based framework for internet

Versions of packages ardour-i686 recommends:
ii  elinks [www-browser]     0.12~pre5-1+b1  advanced text-mode WWW browser
ii  iceweasel [www-browser]  3.5.6-1         lightweight web browser based on M
ii  lynx-cur [www-browser]   2.8.8dev.1-1    Text-mode WWW Browser with NLS sup
ii  midori [www-browser]     0.2.0-1         fast, lightweight graphical web br
ii  opera [www-browser]      9.10-20061214.6 The Opera Web Browser

Versions of packages ardour-i686 suggests:
pn  jamin                         <none>     (no description available)
ii  qjackctl                      0.3.5-1    User interface for controlling the

-- no debconf information



_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to