Package: libavformat52
Version: 4:0.5+svn20090706-2+b1
Severity: important

On my powerpc system, any binary linked against libavformat hits the following
problem:

 nicho...@tracer:~$ mplayer --help
mplayer: error while loading shared libraries: /usr/lib/libavformat.so.52: R_PPC_REL24 relocation at 0x0d925f74 for symbol `fcntl' out of range

For example, 'gnash' also does this. It's possible that the library just needs
to be compiled with -fPIC instead of -fpic?

Nick

-- System Information:
Debian Release: squeeze/sid
 APT prefers unstable
 APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.32-trunk-powerpc

Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libavformat52 depends on:
ii  libavcodec52      4:0.5+svn20090706-2+b1 ffmpeg codec library
ii  libavutil49       4:0.5+svn20090706-2+b1 ffmpeg utility library
ii libbz2-1.0 1.0.5-3 high-quality block-sorting file co
ii  libc6             2.10.2-2               GNU C Library: Shared libraries
ii  zlib1g            1:1.2.3.3.dfsg-15      compression library - runtime

libavformat52 recommends no packages.

libavformat52 suggests no packages.

-- no debconf information




_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to