Package: dirac,lives-data
Version: dirac/1.0.2-2
Version: lives-data/1.1.8-1
Severity: serious
User: trei...@debian.org
Usertags: edos-file-overwrite

Date: 2010-01-11
Architecture: amd64
Distribution: sid

Hi,

automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:


WARNING: The following packages cannot be authenticated!
  libdb4.5 libsqlite3-0 mime-support python2.5-minimal python2.5
  python-minimal python dirac lives-data
W: cowdancer: unsupported operation flock, read-only open and 
fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5408409
W: cowdancer: unsupported operation flock, read-only open and 
fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5407760
W: cowdancer: unsupported operation flock, read-only open and 
fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5407203
Authentication warning overridden.
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously deselected package libdb4.5.
(Reading database ... 10445 files and directories currently installed.)
Unpacking libdb4.5 (from .../libdb4.5_4.5.20-13.1_amd64.deb) ...
Selecting previously deselected package libsqlite3-0.
Unpacking libsqlite3-0 (from .../libsqlite3-0_3.6.21-2_amd64.deb) ...
Selecting previously deselected package mime-support.
Unpacking mime-support (from .../mime-support_3.48-1_all.deb) ...
Selecting previously deselected package python2.5-minimal.
Unpacking python2.5-minimal (from .../python2.5-minimal_2.5.4-3_amd64.deb) ...
Selecting previously deselected package python2.5.
Unpacking python2.5 (from .../python2.5_2.5.4-3_amd64.deb) ...
Selecting previously deselected package python-minimal.
Unpacking python-minimal (from .../python-minimal_2.5.4-5_all.deb) ...
Selecting previously deselected package python.
Unpacking python (from .../python_2.5.4-5_all.deb) ...
Selecting previously deselected package dirac.
Unpacking dirac (from .../dirac_1.0.2-2_amd64.deb) ...
Selecting previously deselected package lives-data.
Unpacking lives-data (from .../lives-data_1.1.8-1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/lives-data_1.1.8-1_all.deb 
(--unpack):
 trying to overwrite '/usr/bin/dirac_encoder', which is also in package dirac 
0:1.0.2-2
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Processing triggers for man-db ...
W: cowdancer: unsupported operation flock, read-only open and 
fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5408409
W: cowdancer: unsupported operation flock, read-only open and 
fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5407760
W: cowdancer: unsupported operation flock, read-only open and 
fchown/fchmod/flock are not supported: tried openning dev:inode of 2055:5407203
Errors were encountered while processing:
 /var/cache/apt/archives/lives-data_1.1.8-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


This is a serious bug as it makes installation fail, and violates
sections 7.6.1 and 10.1 of the policy. An optimal solution would
consist in only one of the packages installing that file, and renaming
or removing the file in the other package. Depending on the
circumstances you might also consider Replace relations or file
diversions. If the conflicting situation cannot be resolved then, as a
last resort, the two packages have to declare a mutual
Conflict. Please take into account that Replaces, Conflicts and
diversions should only be used when packages provide different
implementations for the same functuinality.

Here is a list of files that are known to be shared by both packages
(according to the Contents file for sid/amd64, which may be
slightly out of sync):


  usr/bin/dirac_encoder
  usr/share/man/man1/dirac_encoder.1.gz
  

This bug is assigned to both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package.

-Ralf.

PS: for more information about the detection of file overwrite errors
of this kind see http://edos.debian.net/file-overwrites/.



_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to