On Mon, Apr 26, 2010 at 9:20 AM, Gabriel M. Beddingfield <gabrb...@gmail.com> wrote:

ABI back-compatibility has never been assured - if a program was linked against JACK API M.N.m and the runtime installation is a version earlier than that, there may be problems as you noted. the new rules on weak symbols post the 0.118.0 API should help address this.


Do I understand above correctly so that in fact jackd2 1.9.5 cannot be trusted to support library API (and ABI) of 0.116.2 but only that of 0.118.0?

Tell me if better that I ask upstream such questions. For now I would prefer this list acting as proxy for my perhaps too silly[1] questions.


 - Jonas

[1] No question is too silly to be asked, I know. But some might be silly enough that others than busy upstream developers can answer. :-)

--
* Jonas Smedegaard - idealist & Internet-arkitekt
* Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to