On Mon, 26 Apr 2010, Jonas Smedegaard wrote:

On Mon, Apr 26, 2010 at 9:20 AM, Gabriel M. Beddingfield <gabrb...@gmail.com> wrote:

ABI back-compatibility has never been assured - if a program was linked against JACK API M.N.m and the runtime installation is a version earlier than that, there may be problems as you noted. the new rules on weak symbols post the 0.118.0 API should help address this.

Do I understand above correctly so that in fact jackd2 1.9.5 cannot be trusted to support library API (and ABI) of 0.116.2 but only that of 0.118.0?


If you compiled against the libs from 0.100.0, 0.109.0, 0.116.2, 0.118.0, etc. it will work fine with 1.9.5.

If you compiled against the libs from 1.9.5, it will work fine with >= 0.118.0.


pkg-multimedia-maintainers mailing list

Reply via email to