On Tue, May 11, 2010 17:27, Harry Rickards wrote:
> On 11 May 2010 16:22, Harry Rickards <ha...@linux.com> wrote:
>> Hi,
>>
>> From https://buildd.debian.org/status/package.php?p=lives I can see
>> that armel, hppa and both kfreebsds built 1.3.3-1 fine, whereas on
>> alpha, hurd-i386, i386, ia64, mips, powerpc, s390 and sparc the build
>> failed. On my local machine (i386), the Ubuntu Launchpad PPA builders
>> (i386, amd64 and lpia) and I assume Alessio's machine (amd64) 1.3.3-1
>> built fine. All of the errors seem to be with pgrep being missing. I
>> assume these can be fixed by adding pgrep as a build-dependency.
>> Gabriel, was there something new in 1.3.3 that requires pgrep? Does
>> anyone know why these errors didn't occur on the Launchpad PPA
>> builders (is pgrep maybe installed by default??).
>>
>
> I see that pgrep is provided by procps. This is a package with
> standard priority, so shouldn't it be in buildd by default? The Ubuntu
> version of procps is 1:3.2.8-1ubuntu4, compared to the higher Debian
> version of 1:3.2.8-9 so is it possible an unreported (I had a quick
> look through the bug list and couldn't find anything) bug has somehow
> got into the package between these two Debian revisions?
>
> --
> Harry Rickards - ha...@linux.com
> Vote Lib Dem - Building a fairer Britain - http://libdems.org.uk
>


pgrep is required at runtime, but not for building.


Gabriel.


_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to