On Wed, May 12, 2010 at 20:22, Felipe Sateler <fsate...@gmail.com> wrote:
> On Wed, May 12, 2010 at 19:07, Adrian Knoth <a...@drcomp.erfurt.thur.de> 
> wrote:
>> I'll add both patches to the Debian package.
>
> I'm currently building with both patches to test it.

The patch does not appear to fix the issue.

I got a few successful negotiations, with the following output:


Wed May 12 20:36:01 2010: Starting jack server...
Wed May 12 20:36:01 2010: JACK server starting in realtime mode with priority 20
Wed May 12 20:36:01 2010: Acquired audio card Audio0
Wed May 12 20:36:01 2010: creating alsa driver ...
hw:0|hw:0|64|2|44100|0|0|nomon|swmeter|-|32bit
Wed May 12 20:36:01 2010: Using ALSA driver HDA-Intel running on card
0 - HDA Intel at 0xfe9fc000 irq 21
Wed May 12 20:36:01 2010: configuring for 44100Hz, period = 64 frames
(1.5 ms), buffer = 2 periods
Wed May 12 20:36:01 2010: ALSA: final selected sample format for
capture: 32bit integer little-endian
Wed May 12 20:36:01 2010: ALSA: use 2 periods for capture
Wed May 12 20:36:01 2010: ALSA: final selected sample format for
playback: 32bit integer little-endian
Wed May 12 20:36:01 2010: ALSA: use 2 periods for playback
Wed May 12 20:36:01 2010: graph reorder: new port 'system:capture_1'
Wed May 12 20:36:01 2010: New client 'system' with PID 0
Wed May 12 20:36:01 2010: graph reorder: new port 'system:capture_2'
Wed May 12 20:36:01 2010: graph reorder: new port 'system:playback_1'
Wed May 12 20:36:01 2010: graph reorder: new port 'system:playback_2'
Wed May 12 20:36:01 2010: graph reorder: new port 'system:playback_3'
Wed May 12 20:36:01 2010: graph reorder: new port 'system:playback_4'

THat shows the card had been successfully negotiated (and indeed,
pulseaudio output stopped).

However, after a few times of turning on and off jackd I got the following:

Wed May 12 20:39:28 2010: Starting jack server...
Wed May 12 20:39:28 2010: JACK server starting in realtime mode with priority 20
Wed May 12 20:39:29 2010:  [1m [31mERROR: Failed to acquire device
name : Audio0 error : Input/output error [0m
Wed May 12 20:39:29 2010:  [1m [31mERROR: Audio device hw:0 cannot be
acquired, trying to open it anyway... [0m
Wed May 12 20:39:29 2010: creating alsa driver ...
hw:0|hw:0|64|2|44100|0|0|nomon|swmeter|-|32bit
Wed May 12 20:39:29 2010: Using ALSA driver HDA-Intel running on card
0 - HDA Intel at 0xfe9fc000 irq 21
Wed May 12 20:39:29 2010:  [1m [31mERROR: the playback device "hw:0"
is already in use. Please stop the application using it and run JACK
again [0m
Wed May 12 20:39:29 2010:  [1m [31mERROR: Cannot initialize driver [0m
Wed May 12 20:39:29 2010:  [1m [31mERROR: JackServer::Open() failed with -1 [0m
Wed May 12 20:39:29 2010:  [1m [31mERROR: Failed to start server [0m
Wed May 12 20:39:29 2010:  [1m [31mERROR: Failed to start server [0m


I should note that sometimes, jackd does not give the card back to
pulseaudio. When it doesn't starting and stopping jackd a few times
solves the issue, so its possibly a race condition.

-- 

Saludos,
Felipe Sateler

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to