Source: csound
Version: 1:5.12.1~dfsg-2
Severity: wishlist
Tags: patch
User: pkg-tcltk-de...@lists.alioth.debian.org
Usertags: UpgradeDefaultTclTkTo85

Hi Felipe and Jonas,

To suss out possible problems before making the change for real, it
would be nice if most packages depending on tcl-dev were built against
version 8.5 in experimental.  As discussed on debian-release[1], this
requires sourceful uploads to introduce versioned build-deps on
tcl-dev, tcl, etc, since experimental buildds are a little fussy
about where they get their build-deps from[2].

Rebuilding csound locally, I did not run into any problems.  tclcsound
builds fine against version 8.5, has the correct dependencies, and
examples run okay.  I did not test if sound works but it noticed my
sound card.  To all appearances, everything is fine --- nice job. :)

Anyway, here is a patch to help others test the change.  Once the
updated tcltk-defaults migrates to sid, this change would be useless;
patch is against master but intended for experimental only.  If an NMU
would be simpler, please let me know and I can look for a sponsor.

Thoughts?
Jonathan

[1] http://lists.debian.org/debian-release/2010/03/msg00303.html
[2] http://lists.debian.org/debian-devel-announce/2006/04/msg00007.html

 debian/changelog |    6 ++++++
 debian/control   |    6 ++++--
 debian/rules     |    6 ++++--
 3 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index df75ca0..973ed68 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+csound (1:5.12.1~dfsg-3) experimental; urgency=low
+
+  * Rebuild against tcl/tk 8.5 from experimental.
+
+ -- Jonathan Nieder <jrnie...@gmail.com>  Thu, 20 May 2010 01:54:26 -0500
+
 csound (1:5.12.1~dfsg-2) unstable; urgency=low
 
   * Revert unpatch hack: upsets build daemons.
diff --git a/debian/control b/debian/control
index 754b0d3..4713ac3 100644
--- a/debian/control
+++ b/debian/control
@@ -17,8 +17,10 @@ Build-Depends: cdbs (>= 0.4.73~),
  libpulse-dev,
  swig,
  liblua5.1-0-dev,
- tk-dev,
- tcl-dev,
+ tk-dev (>= 8.5),
+ tk (>= 8.5),
+ tcl-dev (>= 8.5),
+ tcl (>= 8.5),
  python-all-dev (>= 2.3.5-11),
  puredata,
  default-jdk-builddep [alpha amd64 armel hppa hurd-i386 i386 ia64 
kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 sparc],
diff --git a/debian/rules b/debian/rules
index 8236522..8244d6c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -336,8 +336,10 @@ CDBS_BUILD_DEPENDS += , \
 CDBS_BUILD_DEPENDS += , \
        swig, \
        liblua5.1-0-dev, \
-       tk-dev, \
-       tcl-dev, \
+       tk-dev (>= 8.5), \
+       tk (>= 8.5), \
+       tcl-dev (>= 8.5), \
+       tcl (>= 8.5), \
        python-all-dev (>= 2.3.5-11), \
        puredata
 #  * Only build-depend on Java JDK for supported archs
-- 
1.7.1




_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to