On Wed, May 26, 2010 at 17:12, Reinhard Tartler <siret...@tauware.de> wrote:
> On Mi, Mai 26, 2010 at 22:05:58 (CEST), Dmitrijs Ledkovs wrote:
>
>> ifneq (,$(wildcard .git/*))
>>        dh_quilt_unpatch
>> endif
>
> Not bad, but how about in a single line?
>
> ,----
> |       test -d .git && dh_quilt_unpatch
> `----

This will make 'make' fail when not on a git repository.

Jaromir, if you are migrating to 3.0 (quilt) you need to drop the
--with quilt part of dh invocation, I think.


Although, come to think of it, removing explicit quilt support is not
necessary to switch to 3.0. Maybe we are overengineering here? Maybe
dpkg-buildpackage will cope with unpatched trees when creating the
source package? Not at home now, so I can't check. If correct, then
the only thing necessary would be to add the debian/source/format
file.

-- 

Saludos,
Felipe Sateler

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to