On Tue, Jun 15, 2010 at 10:17:43 (CEST), Jonas Smedegaard wrote:

> On Tue, Jun 15, 2010 at 05:57:48AM +0000, 
> adiknoth-gu...@users.alioth.debian.org wrote:
>
>>    Make jackd1 Replace older libjack0 installations.
>
>>-Conflicts: libjack0 (<< 1:0.118+svn3796-4),
>>+Replaces: libjack0 (<< 1:0.118+svn3796-4),
>
> It needs to conflict also: We cannot have multiple packages e.g. provide
> the conffile.

does libjack0 provide a conffile? I don't think so.

>   * Provides: declare package name

rather: implement the named 'virtual' package

>   * Conflicts: require only one implementation installed at a time
>   * Replaces: take over overlapping files (e.g. conffile)

conffile or regular file. in this case: /usr/lib/libjackserver.so.0

> ...that's at least my understanding of it - I might be wrong about some
> details or not cover it all: Read the Debian Policy for official info.

I'm pretty confident that Replaces is correct here and conflicts is not
necessary.

-- 
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to