* Fabian Greffrath (fab...@greffrath.com) wrote:

  |>  Maybe you've got a wild mixture of old and new snd packages installed on 
  |>  your system. Please post the result of "dpkg -l snd\*".

Sorry to be slow (work got in the way) and thank you very much for your help. 
Here
is the output of dpkg -l snd\.*:

dpkg -l snd\*
Desired=Unknown/Install/Remove/Purge/Hold|
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend|/ 
Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                  Version       Description
+++-=====================-=====================-==================
ii  snd                   11.6-1        Sound file editor
un  snd-dmotif            <none>        (no description available)
un  snd-dmotif-alsa       <none>        (no description available)
ii  snd-doc               11.6-1        Sound file editor (documentation)
ii  snd-gtk               7.18-2.2      Sound file editor (GTK+ user interface)
un  snd-gtk-alsa          <none>       (no description available)
un  snd-gtk-jack          <none>       (no description available)
un  snd-gtk-pulse         <none>       (no description available)
un  snd-smotif            <none>       (no description available)
ii  sndfile-programs      1.0.21-2      Sample programs that use libsndfile
ii  sndfile-tools         1.03-2        A collection of programs for operating 
on sound files

Alessio Treglia <ales...@debian.org> wrote:

  |> snd-gtk and snd-alsa are virtual packages provided by snd-gtk-{jack,pulse}.

I understood that these were virtual packages, but what seems to be new is that 
you
can't now run snd unless you use either jackd or pulseaudio. And as far as I can
see at least, this is an undocumented change.

Meanwhile, snd-gtk is still available in the respositories, as of version 
7.18-2.2:

----------------------------------------------------------------------
apt-cache policy snd-gtk
snd-gtk:
  Installed: 7.18-2.2
  Candidate: 7.18-2.2
  Version table:
 *** 7.18-2.2 0
        500 http://ftp.us.debian.org lenny/main Packages
        100 /var/lib/dpkg/status

aptitude show snd-gtk
Package: snd-gtk                         
State: installed
Automatically installed: no
Version: 7.18-2.2
Priority: optional
Section: sound
Maintainer: Guenter Geiger (Debian/GNU) <gei...@debian.org>
Uncompressed Size: 2,748k
Depends: snd (>= 7.18-2.2), guile-1.6-libs, libatk1.0-0 (>= 1.20.0),
libc6 (>= 2.6.1-1), libcairo2 (>=
         1.4.0), libfftw3-3, libfontconfig1 (>= 2.4.0),
         libgl1-mesa-glx | libgl1, libglib2.0-0 (>= 2.14.0),
         libglu1-mesa | libglu1, libgsl0ldbl (>= 1.9), libgtk2.0-0 (>=
         2.12.0), libgtkglext1,
         libguile-ltdl-1, libice6 (>= 1:1.0.0), libjack0 (>= 0.103.0),
         libpango1.0-0 (>= 1.18.2),
         libqthreads-12, libsamplerate0, libsm6, libx11-6,
         libxcomposite1 (>= 1:0.3-1), libxcursor1 (>
         1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3 (>=
         1:4.0.1), libxi6, libxinerama1, libxmu6,
         libxrandr2 (>= 2:1.2.0), libxrender1, libxt6
Conflicts: snd-dmotif, snd-dmotif-alsa, snd-smotif, snd-gtk-alsa
Replaces: snd (< 5.10), snd-dmotif, snd-dmotif-alsa, snd-smotif, snd-gtk-alsa
Provides: snd-gtk-alsa
Provided by: snd-gtk-jack, snd-gtk-pulse
Description: Sound file editor (GTK+ user interface)
 Snd is a powerful sound file editor that can be customized and
 extended using the Scheme programming language. 
 
 URL: http://www-ccrma.stanford.edu/software/snd/ 
 
 This package contains the files for the GTK+ user interface.

Tags: devel::lang:scheme, interface::x11, role::program,
scope::application, uitoolkit::gtk, use::editing,
      use::viewing, works-with::audio, x11::application
----------------------------------------------------------------------

But if it's now possible in Debian to use snd only if one also uses either 
jackd or
pulseaudio, surely that should be documented somewhere (as far as I can see, it
wasn't true before).

I did try to install first jackd and then pulseaudio (along with their 
respective
snd-gtk-{jack,pulse} packages), but I still couldn't get snd to work. I couldn't
find any relevant documentation; the contents of /usr/share/doc/snd-gtk-jack is
just this:

/usr/share/doc/snd-gtk-jack:
  total used in directory 140 available 46325772
  drwxr-xr-x    2 root root  4096 Jun 21 21:40 .
  drwxr-xr-x 2225 root root 90112 Jun 21 21:40 ..
  -rw-r--r--    1 root root  5626 Jun  6 11:46 changelog.Debian.gz
  -rw-r--r--    1 root root 30038 Jun  4 06:23 changelog.gz
  -rw-r--r--    1 root root  1859 Jun  6 11:46 copyright

none of which tells me how I should make jackd and snd talk to each other. 

But thanks for listening and thanks for your help, and thanks for all of your 
work,

Jim

PS the kernel version is: 2.6.32-5-686; 
   alsa is 1.0.23+dfsg-1 from testing/unstable



_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to