reassing 589199 libaubio2
stop

On Sat, Jul 17, 2010 at 17:11:38 (CEST), Adam D. Barratt wrote:

> On Thu, 2010-07-15 at 22:44 -0400, Reinhard Tartler wrote:
>> On Thu, Jul 15, 2010 at 14:23:45 (EDT), Marco wrote:
>> > The following packages have unmet dependencies:
>> >   ardour: Depends: jackd (>= 0.103.0) but it is not going to be installed
>> > E: Broken packages
>> 
>> please share the exact versions of the package and its dependencies you
>> are trying to install. I'm especially curious to see your sources.list,
>> potentially your /etc/apt/preferences (if non-empty/missing).
>> 
>> is this stable? the dependency indicates that the package was built
>> against a copy of libjack not in testing/unstable.
>
> The ardour packages in both testing and unstable depend on "jackd (>=
> 0.103.0)".  Although the exact versioning of the dependency isn't
> mentioned, I'd suspect this was added in 1:2.0~rc1-0ubuntu1, which was
> incorporated in to a package uploaded to Debian in April 2007.

Yes, I'm sorry, this is definitely a problem in current Debian squeeze
and sid. I am able to reproduce it:

r...@debian:/tmp# apt-get install -s ardour 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ardour: Depends: libaubio2 but it is not going to be installed
          Depends: libjack0 (>= 0.118.0) but it is not going to be installed
E: Broken packages


However, this it *is* installable with jackd1:
r...@debian:/tmp# apt-get install -s ardour jackd1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  jackd1-firewire libaubio2 libgnomecanvasmm-2.6-1c2a libjack0 liblo7 liblrdf0 
libvamp-hostsdk3 libvamp-sdk2 python-twisted
  python-twisted-lore python-twisted-mail python-twisted-names 
python-twisted-news python-twisted-runner python-twisted-words
  qjackctl
Suggested packages:
  jamin jack-tools libjackasyn0 meterbridge liblo-dev liblrdf0-dev 
python-twisted-runner-dbg
The following packages will be REMOVED:
  jackd2 jackd2-firewire libjack-jackd2-0
The following NEW packages will be installed:
  ardour jackd1 jackd1-firewire libaubio2 libgnomecanvasmm-2.6-1c2a libjack0 
liblo7 liblrdf0 libvamp-hostsdk3 libvamp-sdk2
  python-twisted python-twisted-lore python-twisted-mail python-twisted-names 
python-twisted-news python-twisted-runner
  python-twisted-words qjackctl
0 upgraded, 18 newly installed, 3 to remove and 0 not upgraded.


just not with jackd2:
r...@debian:/tmp# apt-get install -s ardour jackd2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
jackd2 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ardour: Depends: libaubio2 but it is not going to be installed
          Depends: libjack0 (>= 0.118.0) but it is not going to be installed
E: Broken packages

In order to fix this bug, the package libaubio2 needs to be binNMUed.
In this basis, I'm reassinging this bug to the package libaubio2

Adam, can you please schedule a binNMU?

-- 
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4



_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to