Your message dated Mon, 16 Aug 2010 00:25:11 +0200
with message-id <20100815222511.go7...@jones.dk>
and subject line Re: Bug#593162: audacity: Audacity fails to load libavformat
has caused the Debian Bug report #593162,
regarding audacity: Audacity fails to load libavformat
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
593162: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=593162
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: audacity
Version: 1.3.12-4+b1
Severity: important

When Audacity attempts to load libavformat, it throws the following error in
the log: Error: /usr/lib/libavformat.so.52: undefined symbol: match_ext.
According to my research online, this is because newer versions of ffmpeg
changed the function match_ext to be av_match ext.



-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages audacity depends on:
ii  audacity-data               1.3.12-4     A fast, cross-platform audio edito
ii  libasound2                  1.0.23-1     shared library for ALSA applicatio
ii  libc6                       2.11.2-2     Embedded GNU C Library: Shared lib
ii  libexpat1                   2.0.1-7      XML parsing C library - runtime li
ii  libflac++6                  1.2.1-2+b1   Free Lossless Audio Codec - C++ ru
ii  libflac8                    1.2.1-2+b1   Free Lossless Audio Codec - runtim
ii  libgcc1                     1:4.4.4-8    GCC support library
ii  libglib2.0-0                2.24.1-1     The GLib library of C routines
ii  libgtk2.0-0                 2.20.1-1     The GTK+ graphical user interface 
ii  libid3tag0                  0.15.1b-10   ID3 tag reading library from the M
ii  libmad0                     0.15.1b-5    MPEG audio decoder library
ii  libogg0                     1.2.0~dfsg-1 Ogg bitstream library
ii  libsamplerate0              0.1.7-3      Audio sample rate conversion libra
ii  libsndfile1                 1.0.21-3     Library for reading/writing audio 
ii  libsoundtouch1c2            1.3.1-2      sound stretching library
ii  libstdc++6                  4.4.4-8      The GNU Standard C++ Library v3
ii  libtwolame0                 0.3.12-1     MPEG Audio Layer 2 encoding librar
ii  libvamp-hostsdk3            2.1-1        helper library for Vamp hosts writ
ii  libvorbis0a                 1.3.1-1      The Vorbis General Audio Compressi
ii  libvorbisenc2               1.3.1-1      The Vorbis General Audio Compressi
ii  libvorbisfile3              1.3.1-1      The Vorbis General Audio Compressi
ii  libwxbase2.8-0              2.8.10.1-3   wxBase library (runtime) - non-GUI
ii  libwxgtk2.8-0               2.8.10.1-3   wxWidgets Cross-platform C++ GUI t

Versions of packages audacity recommends:
ii  libavcodec52       5:0.6~svn20100726-0.0 library to encode decode multimedi
ii  libavformat52      5:0.6~svn20100726-0.0 ffmpeg file format library

Versions of packages audacity suggests:
pn  ladspa-plugin                 <none>     (no description available)
ii  libmp3lame0                   3.98.4-0.0 LAME Ain't an MP3 Encoder

-- no debconf information



--- End Message ---
--- Begin Message ---
Hi Aaron,

On Sun, Aug 15, 2010 at 02:27:54PM -0700, Aaron Barany wrote:
When Audacity attempts to load libavformat, it throws the following error in the log: Error: /usr/lib/libavformat.so.52: undefined symbol: match_ext. According to my research online, this is because newer versions of ffmpeg changed the function match_ext to be av_match ext.

Versions of packages audacity recommends:
ii  libavcodec52       5:0.6~svn20100726-0.0 library to encode decode multimedi
ii  libavformat52      5:0.6~svn20100726-0.0 ffmpeg file format library

Above package versions are not official Debian packages.

Debian unfortunately cannot guarantee compatibility with externally built packages.

Please use Debian packages, or work with those unofficial package providers to improve their compatibility with Debian.


Bug hereby closed. Please do tell us if your experienced problem is reproducible using only Debian packages, and we will investigate further.

And please do continue to file bugreports - even if this one is judged as "wrong": We really appreciate the feedback!


Kind regards,

 - Jonas

--
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature


--- End Message ---
_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to