On Di, Sep 28, 2010 at 00:00:29 (CEST), Jonas Smedegaard wrote:

> On Mon, Sep 27, 2010 at 09:43:38PM +0000, 
> adiknoth-gu...@users.alioth.debian.org wrote:
>>    Add Breaks: to ffado-tools.
>>
>>    According to policy 7.6.1, Breaks is required to inform the package
>>    manager to remove older packages upon upgrades.
>>
>>    This hopefully does the trick.
>>
>>diff --git a/debian/control.in b/debian/control.in
>>index e635883..94df4d1 100644
>>--- a/debian/control.in
>>+++ b/debian/control.in
>>@@ -66,6 +66,8 @@ Depends: libffado2 (= ${binary:Version}),
>>  ${shlibs:Depends}
>> Replaces: ffado-mixer-qt4 (<< 2.0.1+svn1856-2~),
>>  ffado-python-support (<= 2.0.1+svn1856-2)
>>+Breaks: ffado-mixer-qt4 (<< 2.0.1+svn1856-2~),
>>+ ffado-python-support (<= 2.0.1+svn1856-2)
>
> I believe Breaks should be used _instead_ of Replaces to have its
> intended benefit.

The move was from Conflicts/Replaces -> Breaks/Replaces to give the
package manager more flexibility for calculating upgrade paths

-- 
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to