On Wed, Oct 20, 2010 at 12:06:10PM +0200, Jonas Smedegaard wrote:

Hi!

> Current packaging of FFADO is versioned 2.0.1+svn1856-1 which supposedly  
> means "Upstream officially released 2.0.1, merged with subsequent SVN  
> rev. 1856, with our rev. one packaging."

Though you're right this interpretation can been derived from the
version number, it's entirely wrong. ;) It's pure svn trunk 1856.

> Problem here is, that upstream apparently (based on the too broad, btw,  
> source origin in our debian/copyright file) only released version 2.0.0.

http://www.ffado.org/?q=release/2.0.1


> So where is the 2.0.1 that our packaging is based on?

Once again, it's not based on 2.0.1.

The whole 2.0 branch on FFADO is a dead-end, everyone uses trunk anyway,
and if we weren't in freeze, I'd instantly update to HEAD, because it
contains important fixes. With the version we're going to release, some
devices won't work. It's a pity, but that's the price for long release
cycles.

http://git.debian.org/?p=pkg-multimedia/ffado.git;a=commitdiff;h=7bfe3b6fcfcc9a59be6d89313ed57ac17ba2b4c2

http://git.debian.org/?p=pkg-multimedia/ffado.git;a=commitdiff;h=1daa1105a1762193b39532c8202974b4e7e493f5


One could argue that the proper package naming should be 2.1.0~svnXXX,
but that's more of a cosmetic thing. We might adapt to this proper naming
after the freeze, if desired.


HTH

-- 
mail: a...@thur.de      http://adi.thur.de      PGP/GPG: key via keyserver

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to