On Sat, Oct 23, 2010 at 01:36:09PM -0300, Felipe Sateler wrote:
1. Make all jack implementations provide: libjack-dev. This leaves us
with unversionable build-depends.


When versioning is needed, the requirement is either a cross-implementation or implementation-specific feature.

For implementation-specific feature the package should build-depend versioned on the specific implementation of JACK.

For cross-implementation feature we should have all implementations provide that new "tag" whenever they mature enough to contain it.

...which I believe leads to my favored approach:

4. Make all jack implementations provide: libjack${tag}-dev.

This is what was done in the past with libjack0.100.0-dev.

We need not change anything now, just use a more meaningful tag than "" next time we want to bump.


 - Jonas

--
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to