On Mon, Oct 25, 2010 at 08:18:23PM -0300, Felipe Sateler wrote:
On Sat, Oct 23, 2010 at 14:09, Jonas Smedegaard <d...@jones.dk> wrote:
On Sat, Oct 23, 2010 at 01:36:09PM -0300, Felipe Sateler wrote:


1. Make all jack implementations provide: libjack-dev. This leaves us with unversionable build-depends.

When versioning is needed, the requirement is either a cross-implementation or implementation-specific feature.

For implementation-specific feature the package should build-depend versioned on the specific implementation of JACK.

For cross-implementation feature we should have all implementations provide that new "tag" whenever they mature enough to contain it.

...which I believe leads to my favored approach:

4. Make all jack implementations provide: libjack${tag}-dev.

This is what was done in the past with libjack0.100.0-dev.

We need not change anything now, just use a more meaningful tag than "" next time we want to bump.


I think this makes most sense. (although it does require renaming libjack-dev to libjack-jackd1-dev and making it Provide: libjack-dev). Note though that there are still a few packages with a versioned build-dependency, although all of them (except xine-lib) require a version already present in lenny:

Fine to get those cleaned up, but I do not consider it urgent: If only they are cleaned out during _next_ feature bump of JACK.


Xine-lib gets the prize for the weirdest build-dep: libjack-dev (>= 0.116-3) | libjack-dev (<< 0.110).

Yeah, that's a good one :-)


 - Jonas

--
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to