If I try to build vlc with older versions of some libraries installed (like
the ones from lenny) I get the following configure errors
configure: error: Library libraw1394 >= 2.0.1 libdc1394-2 >= 2.1.0 needed
for dc1394 was not found
configure: error: Library libpulse >= 0.9.11 needed for pulse was not found
configure: error: Library libmtp >= 1.0.0 needed for mtp was not found
Also I get the following build error
audio.c: In function 'GetVlcAudioFormat':
audio.c:488: error: 'SAMPLE_FMT_DBL' undeclared (first use in this function)
audio.c:488: error: (Each undeclared identifier is reported only once
audio.c:488: error: for each function it appears in.)
which is supposedly solved by using libavcodec52 rather than libavcodec51.
So I think these build-deps need to be versioned.
pkg-multimedia-maintainers mailing list