On Sat, Jan 08, 2011 at 15:24:28 (CET), Jonas Smedegaard wrote:

> On Sat, Jan 08, 2011 at 02:33:34PM +0100, Reinhard Tartler wrote:
>>On Sat, Jan 08, 2011 at 14:14:04 (CET), Jonas Smedegaard wrote:
>>
>>> On Sat, Jan 08, 2011 at 01:00:38PM +0000,
>>> siret...@users.alioth.debian.org wrote:
>>>>    use variable $(X11_LIBS) instead of hardcoded -lX11
>>>
>>>
>>>>-+  -lX11 -lpthread
>>>>++  $(X11_LIBS)
>>>
>>>
>>> Above seems like an accident: Was it deliberate to replace not only
>>> -X11 but also -lpthread there?
>>
>> the -lpthread was added by me a few commits before. I've noticed that
>> doku fixed this bug this way a few minutes before I uploaded it to
>> ubuntu. Anyways, I've taken his approach and it turns out that it
>> builds this way properly, so I've dropped the -lpthread part.
>
> Ah, ok.
>
> I must say it surprised me: you tend to not make errors like that :-)
>
> In the future it would be better IMO to commit such unrelated changes
> separately (or at least mention both in the commit message).  Even if
> just few commits away, that still helps later investigation.

It was not unrelated at all. -lpthread is indeed necessary, but it seems
that it is included magically in $(X11_LIBS).

Or maybe the new upstream version doesn't use anymore -lpthread. But I
got tired to investigate the exact cause and simplified the change.

-- 
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to