On Wed, Jan 12, 2011 at 05:28:54PM +0100, IOhannes m zmoelnig wrote:
while packaging gmerlin-avdecoder i noticed a slight problem with the
build-depends:
it used to be libgmerlin-dev (>= 1.0.0)
but since gmerlin has to be repackaged (to be dfsg compliant), the
actually installed version is 1.0.0~dfsg-1

now i don't understand, why >=1.0.0 is not satisfied with 1.0.0~dfsg-1

everything works fine, if i build-depend on (>= 1.0.0~dfsg)

am i missing something?

and if gmerlin makes a bugfix release that gets rid of the dfsg
problems, so we will be able to create libgmerlin-dev_1.0.1-1, will
(>=1.0.0~dfsg) be satisfied?

The special char ~ means "just below" in Debian-version-speak.

So it makes good sens that a dependency on >=1.0.0 is not satisfied by
=1.0.0~anything-at-all, and that is "just below" 1.0.0.


Hope that helps.

 - Jonas

--
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to