On 2011-02-02 22:35, Miguel Colon wrote:
So looks like a "transition" to me, and we probably need to readjust
ardour's build dependency (to libsoundtouch-dev). I can take care of
this if agreed upon.

Hello, yes it's a transition I was the one that made renamed it.

Perhaps Alessio wants to provide further clarification.

Last time I spoke with Alessio about it from what I understood and
remember he was waiting for post-squeeze. But better to wait for an
official response since I might have misunderstood.

Ardour (perhaps among others) build-depends on libsoundtouch1-dev, but
this is not built by the archive as soundtouch provides
libsoundtouch-dev but not libsoundtouch1-dev. Is this just a typo in
soundtouch packaging, or do we have a more serious problem?

The source packages affected are:
Package: ardour
Package: audacity
Package: djplay
Package: freecycle
Package: gst-plugins-bad0.10
Package: ihu
Package: ocaml-soundtouch
Package: rezound
Package: yatm

In addition:
- liquidsoap just needs to be rebuilt whenever ocaml-soundtouch get
updated since it depends on libsoundtouch-ocaml-dev and not
libsoundtouch directly.
- mixx just needs to be rebuilt since it depends on libsoundtouch-dev
so it should be fine after a binary upload or something.

I basically got this information by adding sid/experimental source
repos to the source.list and doing:
grep-dctrl -FBuild-Depends libsoundtouch  -sPackage
/var/lib/apt/lists/*Sources | sort | uniq
and confirming with apt-cache rdepends (not sure if there was a better
way or if doing it with these 2 commands is not exhaustive enough)

I locally recompiled all the packages in a clean chroot when I made
the initial rename and what I just posted are my notes from that time.
Also, from what I wrote down, all packages except ocaml-soundtouch and
liquidsoap worked with just renaming the build dependency but as luck
would have it ardour is the only package that I forgot to document the
changes I made to it so it would build.

Finally I remember Alessio uploading a new version of audacity and
freecycle to experimental using the renamed library so the transition
on those 2 I assume is done or started.

Hope I made some sense.

Yes, thanks. I just wanted to raise the issue. I looked at djplay and ihu - should I just file FTBFS bugs against them to tell the maintainer to change the build-depend? Unstable seems to be unchanged, there is nothing in experimental (as of packages.debian.org), and it's not under pkg-multimedia's umbrella.

--
David Henningsson, Canonical Ltd.
http://launchpad.net/~diwic

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to