Package: liballegro4.2-dev,libportsmf-dev
Version: liballegro4.2-dev/2:4.2.2-2.2+b1
Version: libportsmf-dev/0.1~svn20101010-1
Severity: serious
User: trei...@debian.org
Usertags: edos-file-overwrite

Date: 2011-04-10
Architecture: amd64
Distribution: sid

Hi,

automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:


WARNING: The following packages cannot be authenticated!
  x11-common libxau6 libxdmcp6 libxcb1 libx11-data libx11-6 libxpm4
  x11proto-core-dev libxau-dev libxdmcp-dev x11proto-input-dev x11proto-kb-dev
  xtrans-dev libpthread-stubs0 libpthread-stubs0-dev libxcb1-dev libx11-dev
  libxpm-dev libasound2 libxfixes3 libxrender1 libxcursor1 libxext6
  libxxf86dga1 libxxf86vm1 liballegro4.2 x11proto-xext-dev libxext-dev
  x11proto-xf86vidmode-dev libxxf86vm-dev x11proto-render-dev libxrender-dev
  x11proto-fixes-dev libxfixes-dev libxcursor-dev liballegro4.2-dev
  libportsmf0 libportsmf-dev

Extracting templates from packages: 78%
Extracting templates from packages: 100%
Preconfiguring packages ...
Authentication warning overridden.
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously deselected package x11-common.
(Reading database ... 8750 files and directories currently installed.)
Unpacking x11-common (from .../x11-common_1%3a7.6+6_all.deb) ...
Selecting previously deselected package libxau6.
Unpacking libxau6 (from .../libxau6_1%3a1.0.6-1_amd64.deb) ...
Selecting previously deselected package libxdmcp6.
Unpacking libxdmcp6 (from .../libxdmcp6_1%3a1.1.0-1_amd64.deb) ...
Selecting previously deselected package libxcb1.
Unpacking libxcb1 (from .../libxcb1_1.7-2_amd64.deb) ...
Selecting previously deselected package libx11-data.
Unpacking libx11-data (from .../libx11-data_2%3a1.4.3-1_all.deb) ...
Selecting previously deselected package libx11-6.
Unpacking libx11-6 (from .../libx11-6_2%3a1.4.3-1_amd64.deb) ...
Selecting previously deselected package libxpm4.
Unpacking libxpm4 (from .../libxpm4_1%3a3.5.9-1_amd64.deb) ...
Selecting previously deselected package x11proto-core-dev.
Unpacking x11proto-core-dev (from .../x11proto-core-dev_7.0.21-2_all.deb) ...
Selecting previously deselected package libxau-dev.
Unpacking libxau-dev (from .../libxau-dev_1%3a1.0.6-1_amd64.deb) ...
Selecting previously deselected package libxdmcp-dev.
Unpacking libxdmcp-dev (from .../libxdmcp-dev_1%3a1.1.0-1_amd64.deb) ...
Selecting previously deselected package x11proto-input-dev.
Unpacking x11proto-input-dev (from .../x11proto-input-dev_2.0.1-1_all.deb) ...
Selecting previously deselected package x11proto-kb-dev.
Unpacking x11proto-kb-dev (from .../x11proto-kb-dev_1.0.5-1_all.deb) ...
Processing triggers for man-db ...
Can not write log, openpty() failed (/dev/pts not mounted?)
Setting up x11-common (1:7.6+6) ...
invoke-rc.d: policy-rc.d denied execution of start.
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously deselected package xtrans-dev.
(Reading database ... 9147 files and directories currently installed.)
Unpacking xtrans-dev (from .../xtrans-dev_1.2.6-1_all.deb) ...
Selecting previously deselected package libpthread-stubs0.
Unpacking libpthread-stubs0 (from .../libpthread-stubs0_0.3-2_amd64.deb) ...
Selecting previously deselected package libpthread-stubs0-dev.
Unpacking libpthread-stubs0-dev (from 
.../libpthread-stubs0-dev_0.3-2_amd64.deb) ...
Selecting previously deselected package libxcb1-dev.
Unpacking libxcb1-dev (from .../libxcb1-dev_1.7-2_amd64.deb) ...
Selecting previously deselected package libx11-dev.
Unpacking libx11-dev (from .../libx11-dev_2%3a1.4.3-1_amd64.deb) ...
Selecting previously deselected package libxpm-dev.
Unpacking libxpm-dev (from .../libxpm-dev_1%3a3.5.9-1_amd64.deb) ...
Selecting previously deselected package libasound2.
Unpacking libasound2 (from .../libasound2_1.0.23-2.1_amd64.deb) ...
Selecting previously deselected package libxfixes3.
Unpacking libxfixes3 (from .../libxfixes3_1%3a4.0.5-1_amd64.deb) ...
Selecting previously deselected package libxrender1.
Unpacking libxrender1 (from .../libxrender1_1%3a0.9.6-1_amd64.deb) ...
Selecting previously deselected package libxcursor1.
Unpacking libxcursor1 (from .../libxcursor1_1%3a1.1.11-1_amd64.deb) ...
Selecting previously deselected package libxext6.
Unpacking libxext6 (from .../libxext6_2%3a1.2.0-2_amd64.deb) ...
Selecting previously deselected package libxxf86dga1.
Unpacking libxxf86dga1 (from .../libxxf86dga1_2%3a1.1.2-1_amd64.deb) ...
Selecting previously deselected package libxxf86vm1.
Unpacking libxxf86vm1 (from .../libxxf86vm1_1%3a1.1.1-1_amd64.deb) ...
Selecting previously deselected package liballegro4.2.
Unpacking liballegro4.2 (from .../liballegro4.2_2%3a4.2.2-2.2+b1_amd64.deb) ...
Selecting previously deselected package x11proto-xext-dev.
Unpacking x11proto-xext-dev (from .../x11proto-xext-dev_7.1.2-1_all.deb) ...
Selecting previously deselected package libxext-dev.
Unpacking libxext-dev (from .../libxext-dev_2%3a1.2.0-2_amd64.deb) ...
Selecting previously deselected package x11proto-xf86vidmode-dev.
Unpacking x11proto-xf86vidmode-dev (from 
.../x11proto-xf86vidmode-dev_2.3.1-1_all.deb) ...
Selecting previously deselected package libxxf86vm-dev.
Unpacking libxxf86vm-dev (from .../libxxf86vm-dev_1%3a1.1.1-1_amd64.deb) ...
Selecting previously deselected package x11proto-render-dev.
Unpacking x11proto-render-dev (from 
.../x11proto-render-dev_2%3a0.11.1-1_all.deb) ...
Selecting previously deselected package libxrender-dev.
Unpacking libxrender-dev (from .../libxrender-dev_1%3a0.9.6-1_amd64.deb) ...
Selecting previously deselected package x11proto-fixes-dev.
Unpacking x11proto-fixes-dev (from .../x11proto-fixes-dev_1%3a5.0-1_all.deb) ...
Selecting previously deselected package libxfixes-dev.
Unpacking libxfixes-dev (from .../libxfixes-dev_1%3a4.0.5-1_amd64.deb) ...
Selecting previously deselected package libxcursor-dev.
Unpacking libxcursor-dev (from .../libxcursor-dev_1%3a1.1.11-1_amd64.deb) ...
Selecting previously deselected package liballegro4.2-dev.
Unpacking liballegro4.2-dev (from 
.../liballegro4.2-dev_2%3a4.2.2-2.2+b1_amd64.deb) ...
Selecting previously deselected package libportsmf0.
Unpacking libportsmf0 (from .../libportsmf0_0.1~svn20101010-1_amd64.deb) ...
Selecting previously deselected package libportsmf-dev.
Unpacking libportsmf-dev (from .../libportsmf-dev_0.1~svn20101010-1_amd64.deb) 
...
dpkg: error processing 
/var/cache/apt/archives/libportsmf-dev_0.1~svn20101010-1_amd64.deb (--unpack):
 trying to overwrite '/usr/include/allegro.h', which is also in package 
liballegro4.2-dev 2:4.2.2-2.2+b1
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/libportsmf-dev_0.1~svn20101010-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


This is a serious bug as it makes installation fail, and violates
sections 7.6.1 and 10.1 of the policy. An optimal solution would
consist in only one of the packages installing that file, and renaming
or removing the file in the other package. Depending on the
circumstances you might also consider Replace relations or file
diversions. If the conflicting situation cannot be resolved then, as a
last resort, the two packages have to declare a mutual
Conflict. Please take into account that Replaces, Conflicts and
diversions should only be used when packages provide different
implementations for the same functionality.

Here is a list of files that are known to be shared by both packages
(according to the Contents file for sid/amd64, which may be
slightly out of sync):

  /usr/include/allegro.h

This bug is assigned to both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package. You may
also register in the BTS that the other package is affected by the bug.

-Ralf.

PS: for more information about the detection of file overwrite errors
of this kind see http://edos.debian.net/file-overwrites/.



_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to