Your message dated Fri, 17 Jun 2011 14:18:44 +0200
with message-id <20110617121844.gw15...@jones.dk>
and subject line Re: Bug#630787: I can not update/install morituri because of a 
syntaxerror
has caused the Debian Bug report #630787,
regarding I can not update/install morituri because of a syntaxerror
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
630787: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=630787
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: morituri
Version: 0.1.2-1
Severity: important


this happens when I try to install this package:

Vormals abgewähltes Paket python-gst0.10 wird gewählt.
(Lese Datenbank ... 323264 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacken von python-gst0.10 (aus .../python-gst0.10_0.10.21-2+b1_i386.deb) ...
Vormals abgewähltes Paket python-musicbrainz2 wird gewählt.
Entpacken von python-musicbrainz2 (aus .../python-musicbrainz2_0.7.3-1_all.deb) 
...
Vormals abgewähltes Paket python-pkg-resources wird gewählt.
Entpacken von python-pkg-resources (aus 
.../python-pkg-resources_0.6.16-1_all.deb) ...
Vormals abgewähltes Paket python-cddb wird gewählt.
Entpacken von python-cddb (aus .../python-cddb_1.4-5.1+b3_i386.deb) ...
Vormals abgewähltes Paket morituri wird gewählt.
Entpacken von morituri (aus .../morituri_0.1.2-1_all.deb) ...
Trigger für man-db werden verarbeitet ...
python-gst0.10 (0.10.21-2+b1) wird eingerichtet ...
python-musicbrainz2 (0.7.3-1) wird eingerichtet ...
python-pkg-resources (0.6.16-1) wird eingerichtet ...
python-cddb (1.4-5.1+b3) wird eingerichtet ...
Trigger für python-central werden verarbeitet ...
morituri (0.1.2-1) wird eingerichtet ...
/usr/lib/python2.3/site-packages/morituri/common/checksum.py:245: 
FutureWarning: hex/oct constants > sys.maxint will return positive values in 
Python 2.4 and up
  checksum &= 0xFFFFFFFF
/usr/lib/python2.3/site-packages/morituri/common/checksum.py:259: 
FutureWarning: hex/oct constants > sys.maxint will return positive values in 
Python 2.4 and up
  checksum &= 0xFFFFFFFF
/usr/lib/python2.3/site-packages/morituri/image/table.py:506: FutureWarning: 
hex/oct constants > sys.maxint will return positive values in Python 2.4 and up
  discId1 &= 0xffffffff
/usr/lib/python2.3/site-packages/morituri/image/table.py:507: FutureWarning: 
hex/oct constants > sys.maxint will return positive values in Python 2.4 and up
  discId2 &= 0xffffffff
Compiling /usr/lib/python2.3/site-packages/morituri/rip/accurip.py ...
  File "/usr/lib/python2.3/site-packages/morituri/rip/accurip.py", line 75
    highest = max(d['confidence'] for d in entries)
                                    ^
SyntaxError: invalid syntax

pycentral: pycentral pkginstall: error byte-compiling files (52)
pycentral pkginstall: error byte-compiling files (52)
dpkg: Fehler beim Bearbeiten von morituri (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
configured to not write apport reports
                                      Trigger für python-support werden 
verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 morituri
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Versuche zu lösen:
morituri (0.1.2-1) wird eingerichtet ...
Compiling /usr/lib/python2.3/site-packages/morituri/rip/accurip.py ...
  File "/usr/lib/python2.3/site-packages/morituri/rip/accurip.py", line 75
    highest = max(d['confidence'] for d in entries)
                                    ^
SyntaxError: invalid syntax

pycentral: pycentral pkginstall: error byte-compiling files (42)
pycentral pkginstall: error byte-compiling files (42)
dpkg: Fehler beim Bearbeiten von morituri (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 morituri
Drücken Sie zum Fortsetzen die Eingabetaste.


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.38.20110331.1 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8) (ignored: LC_ALL 
set to de_DE.UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages morituri depends on:
ii  cdparanoia              3.10.2+debian-10 audio extraction tool for sampling
ii  cdrdao                  1:1.2.3-0.1      records CDs in Disk-At-Once (DAO) 
ii  gstreamer0.10-plugins-g 0.10.29-2        GStreamer plugins from the "good" 
ii  python                  2.6.6-14         interactive high-level object-orie
ii  python-cddb             1.4-5.1+b3       Python interface to CD-IDs and Fre
ii  python-central          0.6.17           register and build utility for Pyt
ii  python-gobject          2.28.6-1         Python bindings for the GObject li
ii  python-gst0.10          0.10.21-2+b1     generic media-playing framework (P
ii  python-gtk2             2.24.0-2         Python bindings for the GTK+ widge
ii  python-musicbrainz2     0.7.3-1          interface to the MusicBrainz XML w
ii  python-pkg-resources    0.6.16-1         Package Discovery and Resource Acc

Versions of packages morituri recommends:
ii  gstreamer0.10-ffmpeg       1:0.10.11-4.1 FFmpeg plugin for GStreamer

Versions of packages morituri suggests:
pn  gstreamer0.10-lame            <none>     (no description available)
pn  python-pycdio                 <none>     (no description available)

-- no debconf information



--- End Message ---
--- Begin Message ---
Hi Manfred,

On 11-06-17 at 01:42pm, Manfred Schmidt-Voigt wrote:
> I just checked all my Python packages and there are also "old"
> packages, which have not been removed by the update processes:
> 
> python2.3/4/5
> 
> My system is realy old. I have never done a complete new install
> since years. So what can I do to let morituri choose the right
> version?

Use aptitude.  Aptitude is your friend. Always use aptitude as your 
package manager.

Do not use apt-get - it is less clever than aptitude.

Do not use GUI tools - they are unavailable in emergency situations 
where you cannot start X11.


Ok, enough of biased preaching, back to your question:

Aptitude is both a command-line and fullscreen tool. The first when 
including a sub-command (e.g. "aptitude install ..."), and the latter 
when invoked without sub-commands:

  aptitude

You can even invoke aptitude as a normal user.  It then switches to root 
using sudo when requested to do actions actually affecting the system.

I suggest you open a non-root terminal, start aptitude in fullscreen 
mode and play with it.  Get familiar with its commands and views.

...and then when you feel able, navigate to the area of obsolete/local 
packages and remove those truly obsolete.


And I suggest to ask on debian-users@ (or one of the localized 
alternatives) for help using aptitude if needed.


I hereby close this as a non-bug.  You can still post to it even when 
closed (only when later "archived" can you no longer post to it).


NB! Please post only to the bugreport, not cc me personally.


Regards,

 - Jonas

-- 
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: Digital signature


--- End Message ---
_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to