Le 17/07/17 à 09:51, Jaromír Mikeš a écrit :



2017-07-15 13:40 GMT+02:00 <bi...@debian.org <mailto:bi...@debian.org>>:

Hi Laurent,

    Your package is {build-}depending against gnome-vfs which is
    deprecated for quite some times now and has been replaced by gvfs.


I've checked B-D of gwc package:
Build-Depends:
 debhelper (>= 10),
 libasound2-dev,
 libfftw3-dev,
 libgnome2-dev,
 libgnomeui-dev,
 libpulse-dev,
 libsndfile1-dev,
 libvorbis-dev

There is no direct B-D on gnome-vfs, but libgnome2-dev need it I guess.

Yes that dependency is indeed pulled by libgnome2 (which is also deprecated) I was not expecting it to leak the dependency like that TBH


    Don't hesitate to contact me if you have any questions.


There is upstream effort to switch to gnome3 what should fix this problem if I understand right.
I am copying upstream devs so they are aware of this issue.

Yes, removing these gnome2 library will fix this bug (and make the Debian GNOME team really happy)

Regards,

Laurent Bigonville


best regards

mira


_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to