Hi

On 2018-02-12 01:01:18, Marco Bodrato wrote:
> Subject: vlc: cvlc plays videos, but vlc crashes
> Followup-For: Bug #852773
> Package: src:vlc
> Version: 3.0.0-1
> 
> Dear Maintainer,
> 
>    * What led up to the situation?
> 
> I just upgraded many programs and libraries, vlc included.
> 
>    * What exactly did you do (or not do) that was effective (or
>      ineffective)?
> 
> Whenever i try to open a video with vlc, it crashes. It happens if I
> double-click on a video from the GUI.
> But it also crashes if I launch "vlc video.mp4" from the command line, or
> if I just launch "vlc", then open the video from the menu.
> In any cases VLC crashes. Everything is fine if I play an audio only file.
> 
> Moreover, launching "cvlc video.mp4" from the command line, correctly
> playes the video...
> 
>    * What was the outcome of this action?
> 
> Segmentation fault

As mentioned in another message to this bug, we are still waiting for a
backtrace. Please install all related -dbgsym package and provide a backtrace.

Thanks.


> -- System Information:
> Debian Release: buster/sid
>   APT prefers unstable
>   APT policy: (2000, 'unstable'), (2000, 'testing')
> Architecture: amd64 (x86_64)
> Foreign Architectures: i386
> 
> Kernel: Linux 4.3.0-1-amd64 (SMP w/2 CPU cores)
> Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash
> Init: systemd (via /run/systemd/system)
> 
> Versions of packages vlc depends on:
> ii  vlc-bin                  3.0.0-1
> ii  vlc-plugin-base          3.0.0-1
> ii  vlc-plugin-qt            3.0.0-1
> ii  vlc-plugin-video-output  3.0.0-1
> 
> Versions of packages vlc recommends:
> ii  vlc-l10n                   3.0.0-1
> ii  vlc-plugin-notify          3.0.0-1
> ii  vlc-plugin-samba           3.0.0-1
> ii  vlc-plugin-skins2          3.0.0-1
> ii  vlc-plugin-video-splitter  3.0.0-1
> ii  vlc-plugin-visualization   3.0.0-1
> 
> vlc suggests no packages.
> 
> Versions of packages libvlc-bin depends on:
> ii  libc6    2.26-6
> ii  libvlc5  3.0.0-1
> 
> Versions of packages libvlc5 depends on:
> ii  libc6        2.26-6
> ii  libvlccore9  3.0.0-1
> 
> Versions of packages libvlc5 recommends:
> ii  libvlc-bin  3.0.0-1
> 
> Versions of packages vlc-bin depends on:
> ii  libc6       2.26-6
> ii  libvlc-bin  3.0.0-1
> ii  libvlc5     3.0.0-1
> 
> Versions of packages vlc-plugin-base depends on:
> ii  liba52-0.7.4                         0.7.4-19
> ii  libarchive13                         3.2.2-3.1
> ii  libaribb24-0                         1.0.3-1
> ii  libasound2                           1.1.3-5
> ii  libass9                              1:0.14.0-1
> ii  libavahi-client3                     0.7-3.1
> ii  libavahi-common3                     0.7-3.1
> ii  libavc1394-0                         0.5.4-4+b1
> ii  libavcodec57                         7:3.4.1-1+b2
> ii  libavformat57                        7:3.4.1-1+b2
> ii  libavutil55                          7:3.4.1-1+b2
> ii  libbasicusageenvironment1            2018.01.29-1
> ii  libbluray2                           1:1.0.2-2
> ii  libc6                                2.26-6
> ii  libcairo2                            1.15.10-1
> ii  libcddb2                             1.3.2-5
> ii  libchromaprint1                      1.4.3-1
> ii  libcrystalhd3                        1:0.0~git20110715.fdd2f19-12
> ii  libdbus-1-3                          1.12.4-1
> ii  libdc1394-22                         2.2.5-1
> ii  libdca0                              0.0.5-10
> ii  libdvbpsi10                          1.3.1-2
> ii  libdvdnav4                           6.0.0-1
> ii  libdvdread4                          6.0.0-1
> ii  libebml4v5                           1.3.5-2
> ii  libfaad2                             2.8.8-1
> ii  libflac8                             1.3.2-1
> ii  libfontconfig1                       2.12.6-0.1
> ii  libfreetype6                         2.8.1-1
> ii  libfribidi0                          0.19.7-2
> ii  libgcc1                              1:7.2.0-19
> ii  libgcrypt20                          1.8.1-4
> ii  libglib2.0-0                         2.54.3-2
> ii  libgnutls30                          3.5.17-1
> ii  libgpg-error0                        1.27-6
> ii  libgroupsock8                        2018.01.29-1
> ii  libharfbuzz0b                        1.7.2-1
> ii  libjpeg62-turbo                      1:1.5.2-2+b1
> ii  libkate1                             0.4.1-7+b1
> ii  liblirc-client0                      0.10.0-2+b1
> ii  liblivemedia62                       2018.01.29-1
> ii  liblua5.2-0                          5.2.4-1.1+b2
> ii  libmad0                              0.15.1b-9
> ii  libmatroska6v5                       1.4.8-1.1
> ii  libmicrodns0                         0.0.8-1
> ii  libmpcdec6                           2:0.1~r495-1+b1
> ii  libmpeg2-4                           0.5.1-8
> ii  libmpg123-0                          1.25.8-1
> ii  libmtp9                              1.1.13-1
> ii  libncursesw5                         6.0+20171125-1
> ii  libnfs8                              1.11.0-3
> ii  libogg0                              1.3.2-1+b1
> ii  libopenmpt-modplug1                  0.3.6-1
> ii  libopus0                             1.2.1-1
> ii  libpng16-16                          1.6.34-1
> ii  libpostproc54                        7:3.4.1-1+b2
> ii  libprotobuf-lite10                   3.0.0-9.1
> ii  libpulse0                            11.1-3
> ii  libraw1394-11                        2.1.2-1+b1
> ii  libresid-builder0c2a                 2.1.1-15
> ii  librsvg2-2                           2.40.20-2
> ii  libsamplerate0                       0.1.9-1
> ii  libsdl-image1.2                      1.2.12-7
> ii  libsdl1.2debian                      1.2.15+dfsg2-0.1
> ii  libsecret-1-0                        0.18.5-6
> ii  libshine3                            3.1.1-1
> ii  libshout3                            2.4.1-2
> ii  libsidplay2                          2.1.1-15
> ii  libsndio6.1                          1.1.0-3
> ii  libsoxr0                             0.1.2-3
> ii  libspeex1                            1.2~rc1.2-1+b2
> ii  libspeexdsp1                         1.2~rc1.2-1+b2
> ii  libssh2-1                            1.8.0-1
> ii  libstdc++6                           7.2.0-19
> ii  libswscale4                          7:3.4.1-1+b2
> ii  libsystemd0                          236-3
> ii  libtag1v5                            1.11.1+dfsg.1-0.2
> ii  libtheora0                           1.1.1+dfsg.1-14+b1
> ii  libtinfo5                            6.0+20171125-1
> ii  libtwolame0                          0.3.13-3
> ii  libudev1                             237-2
> ii  libupnp6                             1:1.6.24-4
> ii  libusageenvironment3                 2018.01.29-1
> ii  libva-drm2                           2.0.0-2
> ii  libva2                               2.0.0-2
> ii  libvlccore9 [vlc-plugin-abi-3-0-0f]  3.0.0-1
> ii  libvorbis0a                          1.3.5-4.1
> ii  libvorbisenc2                        1.3.5-4.1
> ii  libx264-152                          2:0.152.2854+gite9a5903-2
> ii  libx265-146                          2.6-3
> ii  libxcb-keysyms1                      0.4.0-1+b2
> ii  libxcb1                              1.12-1
> ii  libxml2                              2.9.4+dfsg1-6.1
> ii  libzvbi0                             0.2.35-13
> ii  vlc-data                             3.0.0-1
> ii  zlib1g                               1:1.2.8.dfsg-5
> 
> Versions of packages vlc-plugin-base recommends:
> ii  xdg-utils  1.1.2-1
> 
> Versions of packages vlc-plugin-base suggests:
> ii  libdvdcss2  1.4.1-dmo1
> 
> Versions of packages vlc-plugin-notify depends on:
> ii  libc6                                2.26-6
> ii  libgdk-pixbuf2.0-0                   2.36.11-1
> ii  libglib2.0-0                         2.54.3-2
> ii  libgtk-3-0                           3.22.26-2
> ii  libnotify4                           0.7.7-3
> ii  libvlccore9 [vlc-plugin-abi-3-0-0f]  3.0.0-1
> 
> Versions of packages vlc-plugin-qt depends on:
> ii  libc6                                2.26-6
> ii  libgcc1                              1:7.2.0-19
> ii  libqt5core5a                         5.9.2+dfsg-4
> ii  libqt5gui5                           5.9.2+dfsg-4
> ii  libqt5svg5                           5.9.2-3
> ii  libqt5widgets5                       5.9.2+dfsg-10
> ii  libqt5x11extras5                     5.9.2-1
> ii  libstdc++6                           7.2.0-19
> ii  libvlccore9 [vlc-plugin-abi-3-0-0f]  3.0.0-1
> ii  libwayland-client0                   1.14.0-1+b1
> ii  libx11-6                             2:1.6.4-3
> 
> Versions of packages vlc-plugin-qt recommends:
> ii  vlc-bin  3.0.0-1
> 
> Versions of packages vlc-plugin-skins2 depends on:
> ii  fonts-freefont-ttf                   20120503-7
> ii  libc6                                2.26-6
> ii  libfreetype6                         2.8.1-1
> ii  libfribidi0                          0.19.7-2
> ii  libgcc1                              1:7.2.0-19
> ii  libstdc++6                           7.2.0-19
> ii  libvlccore9 [vlc-plugin-abi-3-0-0f]  3.0.0-1
> ii  libx11-6                             2:1.6.4-3
> ii  libxext6                             2:1.3.3-1+b2
> ii  libxinerama1                         2:1.1.3-1+b3
> ii  libxpm4                              1:3.5.12-1
> ii  vlc-plugin-qt                        3.0.0-1
> 
> Versions of packages vlc-plugin-skins2 recommends:
> ii  vlc-bin  3.0.0-1
> 
> Versions of packages vlc-plugin-video-output depends on:
> ii  libaa1                                  1.4p5-44+b1
> ii  libavcodec57                            7:3.4.1-1+b2
> ii  libavutil55                             7:3.4.1-1+b2
> ii  libc6                                   2.26-6
> ii  libcaca0                                0.99.beta19-2+b2
> ii  libegl1                                 1.0.0-2
> ii  libgl1-mesa-glx [libgl1]                17.1.5-1
> ii  libgles2-mesa [libgles2]                17.1.5-1
> ii  libplacebo3                             0.3.0-2
> ii  libva-drm2                              2.0.0-2
> ii  libva-wayland2                          2.0.0-2
> ii  libva-x11-2                             2.0.0-2
> ii  libva2                                  2.0.0-2
> ii  libvlccore9 [vlc-plugin-abi-3-0-0f]     3.0.0-1
> ii  libwayland-client0                      1.14.0-1+b1
> ii  libwayland-egl1-mesa [libwayland-egl1]  17.3.3-1
> ii  libx11-6                                2:1.6.4-3
> ii  libxcb-keysyms1                         0.4.0-1+b2
> ii  libxcb-shm0                             1.12-1
> ii  libxcb-xv0                              1.12-1
> ii  libxcb1                                 1.12-1
> 
> Versions of packages vlc-plugin-video-splitter depends on:
> ii  libc6                                2.26-6
> ii  libvlccore9 [vlc-plugin-abi-3-0-0f]  3.0.0-1
> ii  libxcb-randr0                        1.12-1
> ii  libxcb1                              1.12-1
> 
> Versions of packages vlc-plugin-visualization depends on:
> ii  libc6                                2.26-6
> ii  libgl1-mesa-glx [libgl1]             17.1.5-1
> ii  libvlccore9 [vlc-plugin-abi-3-0-0f]  3.0.0-1
> 
> -- no debconf information
> 
> 
> -- 
> http://bodrato.it/papers/
> 
> _______________________________________________
> pkg-multimedia-maintainers mailing list
> pkg-multimedia-maintainers@lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-multimedia-maintainers

-- 
Sebastian Ramacher

Attachment: signature.asc
Description: PGP signature

_______________________________________________
pkg-multimedia-maintainers mailing list
pkg-multimedia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-multimedia-maintainers

Reply via email to