The following commit has been merged in the master branch:
commit 95a5f8c7572ad2279cae6aec5a7ab2300fd5adc6
Author: Mehdi Dogguy <me...@debian.org>
Date:   Sat Apr 23 19:55:25 2011 +0200

    Bump minimum version of Coq to 8.3

diff --git a/debian/changelog b/debian/changelog
index 3c55bab..8f36f6a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,8 +4,11 @@ why (2.29+dfsg-1) unstable; urgency=low
     - Remove old patches, which are not needed anymore.
     - Remove build-depends on coq-float (upstream switched to Flocq which
       is not packaged yet).
+  * Bump minimum version of Coq to 8.3
+    - and add 0001-Why-2.29-do-support-Coq-8.3.patch (upstream forgot to
+      mention to why-config that Coq 8.3 is "ok").
 
- -- Mehdi Dogguy <me...@debian.org>  Sat, 23 Apr 2011 19:45:08 +0200
+ -- Mehdi Dogguy <me...@debian.org>  Sat, 23 Apr 2011 19:54:56 +0200
 
 why (2.26+dfsg-4) unstable; urgency=low
 
diff --git a/debian/control b/debian/control
index c9fb630..90b9d16 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,7 @@ Build-Depends:
   ocaml-best-compilers,
   camlp4,
   liblablgtk2-ocaml-dev (>= 2.12.0-3~),
-  coq (>= 8.2.pl1~),
+  coq (>= 8.3~),
   libocamlgraph-ocaml-dev (>= 1.4~),
   frama-c-base (>= 20100401+boron+dfsg-4~),
   libapron-ocaml-dev (>= 0.9.10-4~),
diff --git a/debian/patches/0001-Why-2.29-do-support-Coq-8.3.patch 
b/debian/patches/0001-Why-2.29-do-support-Coq-8.3.patch
new file mode 100644
index 0000000..8e814e7
--- /dev/null
+++ b/debian/patches/0001-Why-2.29-do-support-Coq-8.3.patch
@@ -0,0 +1,22 @@
+From: Mehdi Dogguy <me...@debian.org>
+Date: Sat, 23 Apr 2011 20:03:16 +0200
+Subject: [PATCH] Why 2.29 do support Coq 8.3
+
+---
+ tools/dpConfig.ml |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tools/dpConfig.ml b/tools/dpConfig.ml
+index edaf366..8856081 100644
+--- a/tools/dpConfig.ml
++++ b/tools/dpConfig.ml
+@@ -199,7 +199,7 @@ let coq =
+     version = "";
+     version_switch = "-v";
+     version_regexp = "The Coq Proof Assistant, version \\([^ ]+\\)";
+-    versions_ok = ["8.0"; "8.1";"8.2";"8.2pl1"];
++    versions_ok = ["8.0"; "8.1";"8.2";"8.2pl1";"8.3pl2"];
+     versions_old = ["7.4"];
+     command = "coqc";
+     command_switches = "";
+-- 
diff --git a/debian/patches/series b/debian/patches/series
index e69de29..e427227 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Why-2.29-do-support-Coq-8.3.patch

-- 
why packaging

_______________________________________________
Pkg-ocaml-maint-commits mailing list
Pkg-ocaml-maint-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-ocaml-maint-commits

Reply via email to