The following commit has been merged in the master branch:
commit 67ef5ec22bdcc9d1484123e2e422463a74efb983
Author: Stephane Glondu <st...@glondu.net>
Date:   Sat Dec 3 17:58:52 2011 +0100

    Accept ocamlgraph 1.8*

diff --git a/debian/changelog b/debian/changelog
index c1a9293..ec8c2d9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+frama-c (20110201+carbon+dfsg-3) UNRELEASED; urgency=low
+
+  * Accept ocamlgraph 1.8*
+
+ -- St├ęphane Glondu <glo...@debian.org>  Sat, 03 Dec 2011 17:59:23 +0100
+
 frama-c (20110201+carbon+dfsg-2) unstable; urgency=low
 
   * Add "-I +ocamlgraph" to DYN_{O,B}LINKFLAGS, needed for plugins to link.
diff --git a/debian/patches/0004-Accept-ocamlgraph-1.8.patch 
b/debian/patches/0004-Accept-ocamlgraph-1.8.patch
new file mode 100644
index 0000000..9b1d3e8
--- /dev/null
+++ b/debian/patches/0004-Accept-ocamlgraph-1.8.patch
@@ -0,0 +1,36 @@
+From: Stephane Glondu <st...@glondu.net>
+Date: Sat, 3 Dec 2011 17:58:39 +0100
+Subject: Accept ocamlgraph 1.8*
+
+---
+ configure    |    2 +-
+ configure.in |    2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure b/configure
+index 89ba34d..b5b6835 100755
+--- a/configure
++++ b/configure
+@@ -3108,7 +3108,7 @@ if test "$OCAMLGRAPH_EXISTS" = "yes"; then
+   then
+     OCAMLGRAPH_VERSION=`./test_ocamlgraph`
+     case $OCAMLGRAPH_VERSION in
+-    1.7) { $as_echo "$as_me:${as_lineno-$LINENO}: OcamlGraph 
$OCAMLGRAPH_VERSION found: great!" >&5
++    1.[78]*) { $as_echo "$as_me:${as_lineno-$LINENO}: OcamlGraph 
$OCAMLGRAPH_VERSION found: great!" >&5
+ $as_echo "$as_me: OcamlGraph $OCAMLGRAPH_VERSION found: great!" >&6;};;
+     *)   { $as_echo "$as_me:${as_lineno-$LINENO}: OcamlGraph 
$OCAMLGRAPH_VERSION is incompatible with Frama-C." >&5
+ $as_echo "$as_me: OcamlGraph $OCAMLGRAPH_VERSION is incompatible with 
Frama-C." >&6;}
+diff --git a/configure.in b/configure.in
+index 79e197b..6a64d8b 100644
+--- a/configure.in
++++ b/configure.in
+@@ -240,7 +240,7 @@ if test "$OCAMLGRAPH_EXISTS" = "yes"; then
+   then
+     OCAMLGRAPH_VERSION=`./test_ocamlgraph`
+     case $OCAMLGRAPH_VERSION in
+-    1.7) AC_MSG_NOTICE([OcamlGraph $OCAMLGRAPH_VERSION found: great!]);;
++    1.[78]*) AC_MSG_NOTICE([OcamlGraph $OCAMLGRAPH_VERSION found: great!]);;
+     *)   AC_MSG_NOTICE([OcamlGraph $OCAMLGRAPH_VERSION is incompatible with 
Frama-C.])
+          OCAMLGRAPH_EXISTS=no
+        OCAMLGRAPH_INCLUDE=;;
+-- 
diff --git a/debian/patches/series b/debian/patches/series
index 43a7827..5e1b27b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
 0001-Value-Analysis-Carbon-patchlevel-1.patch
 0002-Fix-for-issue-727.patch
 0003-Add-ocamlgraph-to-DYN_-O-B-LINKFLAGS.patch
+0004-Accept-ocamlgraph-1.8.patch

-- 
frama-c packaging

_______________________________________________
Pkg-ocaml-maint-commits mailing list
Pkg-ocaml-maint-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ocaml-maint-commits

Reply via email to