The following commit has been merged in the master branch:
commit 976f6a56a85cf51d9e57fd06873ad2446cb9853d
Author: Ralf Treinen <trei...@free.fr>
Date:   Thu May 31 22:12:25 2012 +0200

    rewrite apt-cued-get manpage as suggested by Roberto

diff --git a/debian/apt-cudf-get.pod b/debian/apt-cudf-get.pod
index 410f840..991cde3 100644
--- a/debian/apt-cudf-get.pod
+++ b/debian/apt-cudf-get.pod
@@ -13,21 +13,34 @@ apt-cudf-get - wrapper for calling apt-get with external 
solvers
 
 =head1 DESCRIPTION
 
-B<apt-cudf-get> is a wrapper that in some situations is useful to
-invoke B<apt-get> with external solvers. All options are passed on to
-B<apt-get>.
-
-The is is useful is when one wishes to relax apt's pinning. Normally,
-apt uses so-called pinning to select a candidate version of a package
-in case there are several versions available. A priori this also holds
-when calling apt-get with external solvers. However, it may be useful
-to relax pinning and to allow the external solver to choose among all
-available versions of packages in order to satisfy dependencies, not
-only those that are selected by the pinning. Note that in this case the
-versions of packages that are given as arguments to B<install> on the
-command line are still selected according to apt's pinning, the
-relaxation of pinning only applies to the dependencies that may be
-necessary to install
+B<apt-cudf-get> is a wrapper that allows to invoke B<apt-get> with
+external solvers while ignoring apt's pinning.
+
+All options are passed on to apt-get.
+
+Normally, apt uses so-called pinning to select a candidate version of
+a package in case there are several versions available. This also
+holds when calling apt-get with external solvers. However, when it is
+not possible to find a solution under this constraint, it may be
+useful to relax pinning and to allow the external solver to choose
+among all available versions of packages in order to satisfy
+dependencies, not only those that are selected by the pinning.  This
+is precisely what apt-cudf-get does.
+
+Note that, when using an external solver, the proposed solution may
+contain any available version of the packages that are given as
+arguments to install on the command line without specifying a version
+qualifier.
+
+For example
+
+    apt-cudf-get --solver aspcud install ocaml
+
+may propose to install any available version of ocaml, while
+
+    apt-cudf-get --solver aspcud install ocaml=4.01.0
+
+will only propose to install ocaml in version 4.01.0
 
 =head1 AUTHOR
 
diff --git a/debian/changelog b/debian/changelog
index e4d7b75..0fba91a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,7 +10,7 @@ dose3 (2.9.17-1) unstable; urgency=low
   * New file debian/apt-cudf-get, install into /usr/bin
   * Write a manpage for apt-cudf-get, install in the apt-cudf package.
 
- -- Ralf Treinen <trei...@debian.org>  Thu, 31 May 2012 21:27:30 +0200
+ -- Ralf Treinen <trei...@debian.org>  Thu, 31 May 2012 22:35:14 +0200
 
 dose3 (2.9.15-1) unstable; urgency=low
 

-- 
dose3 packaging

_______________________________________________
Pkg-ocaml-maint-commits mailing list
Pkg-ocaml-maint-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ocaml-maint-commits

Reply via email to