The following commit has been merged in the master branch:
commit 3af4ac55a6b29f4e50fe305ebc73f9d0d00113c6
Author: Mehdi Dogguy <me...@debian.org>
Date:   Tue Jun 25 21:15:31 2013 +0200

    Fix outdated-autotools-helper-file config.guess

diff --git a/debian/changelog b/debian/changelog
index 2d2dffd..f066342 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ ocaml-zarith (1.2.1-1) UNRELEASED; urgency=low
 
   * New upstream release
   * Make libzarith-ocaml-dev depend on libgmp3-dev. (Closes: #714088)
+  * Fix outdated-autotools-helper-file config.guess
+    * Add autotools-dev in Build-Depends
 
  -- Mehdi Dogguy <me...@debian.org>  Tue, 25 Jun 2013 20:57:55 +0200
 
diff --git a/debian/control b/debian/control
index b1dd34e..fa43060 100644
--- a/debian/control
+++ b/debian/control
@@ -8,6 +8,7 @@ Build-Depends:
   ocaml-nox (>= 3.12.1),
   dh-ocaml (>= 0.9.1),
   libgmp3-dev,
+  autotools-dev,
   ocaml-findlib
 Standards-Version: 3.9.3
 Vcs-Browser: http://git.debian.org/?p=pkg-ocaml-maint/packages/ocaml-zarith.git
diff --git a/debian/rules b/debian/rules
index 4dc7b34..fde94fc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,11 @@ endif
 endif
 
 override_dh_auto_configure:
+       for ext in guess; do \
+               if [ -f /usr/share/misc/config.$$ext ]; then \
+                       cp -f /usr/share/misc/config.$$ext 
$(CURDIR)/config.$$ext; \
+               fi; \
+       done
        ./configure --installdir $(Z_INSTALL_DIR) \
                     --host $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 

-- 
ocaml-zarith packaging

_______________________________________________
Pkg-ocaml-maint-commits mailing list
Pkg-ocaml-maint-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ocaml-maint-commits

Reply via email to