This is an automated email from the git hooks/post-receive script.

infinity0 pushed a commit to branch master
in repository ocaml.

commit 7e85810bde74803ef050871500503f9e418db8a8
Author: Ximin Luo <infini...@debian.org>
Date:   Wed Nov 2 12:19:43 2016 +0100

    Make ocaml-best-compilers non-virtual so that we can have versioned 
Build-Depends on it
---
 debian/changelog  |  2 ++
 debian/control    | 21 ++++++++++++++++++++-
 debian/control.in | 24 ++++++++++++++++++++++--
 debian/rules      |  4 +++-
 4 files changed, 47 insertions(+), 4 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 8699857..ae8905a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
 ocaml (4.03.0-3) UNRELEASED; urgency=medium
 
   * Default to PIC on arm, to fix failing armhf tests.
+  * Make ocaml-best-compilers non-virtual so that we can have versioned
+    Build-Depends on it.
 
  -- Ximin Luo <infini...@debian.org>  Wed, 02 Nov 2016 04:02:05 +0100
 
diff --git a/debian/control b/debian/control
index 085b2ee..6f67f9f 100644
--- a/debian/control
+++ b/debian/control
@@ -153,7 +153,6 @@ Depends:
  gcc, binutils,
  ${shlibs:Depends},
  ${misc:Depends}
-Provides: ocaml-best-compilers
 Replaces: ocaml-nox (<= 3.09.2-3)
 Description: Native code compilers of the OCaml suite (the .opt ones)
  Objective Caml (OCaml) is an implementation of the ML language, based on
@@ -197,6 +196,26 @@ Description: OCaml interactive interpreter and standard 
libraries
  This package contains the files required to run an OCaml shell from the
  command line.
 
+Package: ocaml-best-compilers
+Architecture: any
+Depends:
+ ocaml-native-compilers [amd64 arm64 armel armhf hurd-i386 i386 kfreebsd-i386 
kfreebsd-amd64 lpia powerpc ppc64 ppc64el sparc s390x],
+ ocaml-interp [!amd64 !arm64 !armel !armhf !hurd-i386 !i386 !kfreebsd-i386 
!kfreebsd-amd64 !lpia !powerpc !ppc64 !ppc64el !sparc !s390x],
+ ${shlibs:Depends},
+ ${misc:Depends}
+Description: Best code compilers of the OCaml suite
+ Objective Caml (OCaml) is an implementation of the ML language, based on
+ the Caml Light dialect extended with a complete class-based object system
+ and a powerful module system in the style of Standard ML.
+ .
+ This package is an empty metapackage for use as a versioned Build-Depends.
+ It depends on ocaml-native-compilers if it is available on the selected
+ architecture, otherwise it depends on ocaml-interp.
+ .
+ Normal users do not need to install this package, and it may be turned back
+ into a virtual package in the future, if Debian adds support for versioned
+ virtual Build-Depends.
+
 Package: ocaml-compiler-libs
 Architecture: any
 Depends:
diff --git a/debian/control.in b/debian/control.in
index 140f561..d61b0c5 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -6,7 +6,8 @@ Uploaders:
  Samuel Mimram <smim...@debian.org>,
  Ralf Treinen <trei...@debian.org>,
  St├ęphane Glondu <glo...@debian.org>,
- Mehdi Dogguy <me...@debian.org>
+ Mehdi Dogguy <me...@debian.org>,
+ Ximin Luo <infini...@debian.org>
 Build-Depends:
  debhelper (>= 9),
  pkg-config,
@@ -152,7 +153,6 @@ Depends:
  gcc, binutils,
  ${shlibs:Depends},
  ${misc:Depends}
-Provides: ocaml-best-compilers
 Replaces: ocaml-nox (<= 3.09.2-3)
 Description: Native code compilers of the OCaml suite (the .opt ones)
  Objective Caml (OCaml) is an implementation of the ML language, based on
@@ -196,6 +196,26 @@ Description: OCaml interactive interpreter and standard 
libraries
  This package contains the files required to run an OCaml shell from the
  command line.
 
+Package: ocaml-best-compilers
+Architecture: any
+Depends:
+ ocaml-native-compilers [@OCamlNativeArchs@],
+ ocaml-interp [@NegateOCamlNativeArchs@],
+ ${shlibs:Depends},
+ ${misc:Depends}
+Description: Best code compilers of the OCaml suite
+ Objective Caml (OCaml) is an implementation of the ML language, based on
+ the Caml Light dialect extended with a complete class-based object system
+ and a powerful module system in the style of Standard ML.
+ .
+ This package is an empty metapackage for use as a versioned Build-Depends.
+ It depends on ocaml-native-compilers if it is available on the selected
+ architecture, otherwise it depends on ocaml-interp.
+ .
+ Normal users do not need to install this package, and it may be turned back
+ into a virtual package in the future, if Debian adds support for versioned
+ virtual Build-Depends.
+
 Package: ocaml-compiler-libs
 Architecture: any
 Depends:
diff --git a/debian/rules b/debian/rules
index 4df28eb..9495a92 100755
--- a/debian/rules
+++ b/debian/rules
@@ -88,7 +88,9 @@ ocamlinit-stamp: $(TARBALL_TARGET)
 # Should never be called automatically.
 .PHONY: debian/control
 debian/control:
-       sed -e 's/@OCamlNativeArchs@/$(OCAML_NATIVE_ARCHS)/g' debian/control.in 
> $@
+       sed -e 's/@OCamlNativeArchs@/$(OCAML_NATIVE_ARCHS)/g' debian/control.in 
| \
+       sed -e 's/@NegateOCamlNativeArchs@/$(OCAML_NATIVE_ARCHS:%=!%)/g' > \
+       $@
 
 pre-config-stamp: $(TARBALL_TARGET)
        chmod +x debian/gen_modules.pl

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-ocaml-maint/packages/ocaml.git

_______________________________________________
Pkg-ocaml-maint-commits mailing list
Pkg-ocaml-maint-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ocaml-maint-commits

Reply via email to