This is an automated email from the git hooks/post-receive script.

treinen pushed a commit to branch master
in repository ppx-derivers.

commit 16e1c9ada79094417f7ad5f35537eb96da1a7d02
Author: Ralf Treinen <trei...@debian.org>
Date:   Mon Oct 16 21:33:30 2017 +0200

    initial
---
 debian/changelog                            |  6 ++++++
 debian/compat                               |  1 +
 debian/control                              | 29 +++++++++++++++++++++++++++++
 debian/libppx-derivers-ocaml-dev.install.in |  2 ++
 debian/rules                                |  7 +++++++
 5 files changed, 45 insertions(+)

diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..be521c4
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+ppx-derivers (1.0-1) unstable; urgency=medium
+
+  * Initial package (closes: #878803)
+
+ -- Ralf Treinen <trei...@debian.org>  Mon, 16 Oct 2017 21:32:30 +0200
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..f599e28
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..9992a8d
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,29 @@
+Source: ppx-derivers
+Section: ocaml
+Priority: optional
+Maintainer: Debian OCaml Maintainers <debian-ocaml-ma...@lists.debian.org>
+Uploaders: Ralf Treinen <trei...@debian.org>
+Build-Depends:
+ debhelper (>= 10),
+ dh-ocaml,
+ ocaml-nox,
+ jbuilder (>= 1.0~beta7)
+Standards-Version: 4.1.1
+Vcs-Browser: 
https://anonscm.debian.org/git/pkg-ocaml-maint/packages/ppx-derivers.git
+Vcs-Git: 
https://anonscm.debian.org/git/pkg-ocaml-maint/packages/ppx-derivers.git
+Homepage: https://github.com/diml/ppx_derivers
+
+Package: libppx-derivers-ocaml-dev
+Provides:
+ ${ocaml:Provides}
+Architecture: any
+Depends:
+ ${ocaml:Depends},
+ ${shlibs:Depends},
+ ${misc:Depends}
+Description: interoperability of ppx-deriving and ppx-type-conv
+ This package is useful when programming with ppx syntax extensions in
+ the OCaml programming language. Its purpose is to allow the ppx_deriving
+ and ppx_type_conv syntax extensions to interoperate gracefully when linked
+ as part of the same ocaml-migrate-parsetree driver.
+
diff --git a/debian/libppx-derivers-ocaml-dev.install.in 
b/debian/libppx-derivers-ocaml-dev.install.in
new file mode 100644
index 0000000..364acc3
--- /dev/null
+++ b/debian/libppx-derivers-ocaml-dev.install.in
@@ -0,0 +1,2 @@
+_build/install/default/lib/ppx_derivers/META            
@OCamlStdlibDir@/ppx_derivers
+_build/install/default/lib/ppx_derivers/ppx_derivers.*  
@OCamlStdlibDir@/ppx_derivers
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8140b3e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,7 @@
+#!/usr/bin/make -f
+
+%:
+       dh $@ --with ocaml
+
+# upstream's install target is for opam
+override_dh_auto_install:

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-ocaml-maint/packages/ppx-derivers.git

_______________________________________________
Pkg-ocaml-maint-commits mailing list
Pkg-ocaml-maint-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ocaml-maint-commits

Reply via email to