On Wed, 04 Jan 2012 00:08:56 +0300, Andrew O. Shadura wrote:

> Currently, /usr/bin/josm wrapper script does the following:
> 
>   JAVA_OPTS="$JAVA_OPTS -Djava.net.preferIPv4Stack=true
> -Djava.net.useSystemProxies=true"
> 
> This is wrong, IPv6 should be preferred, not IPv4. At any rate, this
> can be configurable and not hard-coded in the wrapper script. Please
> remove this setting.

That was done because Java was broken with "IPv6 preferred". So I'm not really
doing this until I have a reasonably large number of people telling me that,
with various network setups, removing -Djava.net.prefer* is safe.

So, you're the first :)

Kindly,
David

-- 
 . ''`.   Debian developer | http://wiki.debian.org/DavidPaleino
 : :'  : Linuxer #334216 --|-- http://www.hanskalabs.net/
 `. `'`  GPG: 1392B174 ----|---- http://deb.li/dapal
   `-   2BAB C625 4E66 E7B8 450A C3E1 E6AA 9017 1392 B174

Attachment: signature.asc
Description: PGP signature

_______________________________________________
Pkg-osm-maint mailing list
Pkg-osm-maint@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-osm-maint

Reply via email to