Package: josm
Version: 0.0.svn4878+dfsg1-1
Severity: important

Hi,

I think I've found a bug with your wrapper script for JOSM. It says "No valid 
JVM found" when only openjdk-7 is installed. The script appears to only checks 
for openjdk-6 and then fall back to Sun Java.

It does work fine with OpenJDK 7, though, if you start it with "JAVACMD=java 
jsom" (features I tested: install Building plugin, use Bing background, 
download/upload data)

Regards,
Samuel


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-1-686-pae (SMP w/1 CPU core)
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages josm depends on:
ii  ant                              1.8.2-4
ii  libcommons-codec-java            1.5-1
ii  libgettext-commons-java          0.9.6-2
ii  libmetadata-extractor-java       2.3.1+dfsg-2
ii  liboauth-signpost-java           1.2.1.1-1
ii  libsvgsalamander-java            0~svn95-1
ii  openjdk-7-jre                    7~u3-2.1-1
ii  openstreetmap-map-icons-classic  1:0.0.svn26700-1

Versions of packages josm recommends:
ii  josm-plugins      0.0.svn27676+ds1-1
ii  webkit-image-gtk  0.0.svn25399-2+b1

josm suggests no packages.

-- no debconf information



_______________________________________________
Pkg-osm-maint mailing list
Pkg-osm-maint@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-osm-maint

Reply via email to