Your message dated Wed, 27 Jun 2012 07:50:20 +0000
with message-id <e1sjn12-0004pa...@franck.debian.org>
and subject line Bug#621487: fixed in osm-gps-map 0.7.3-2
has caused the Debian Bug report #621487,
regarding osm-gps-map: Please stop installing la-file in dev-package (Policy 
10.2)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
621487: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=621487
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: osm-gps-map
Version: 0.7.2-1
Severity: normal
Tags: patch
User: ubuntu-de...@lists.ubuntu.com
Usertags: origin-ubuntu natty ubuntu-patch



*** /tmp/tmpVfu9xG
In Ubuntu, the attached patch was applied to achieve the following:

  * debian/libosmgpsmap-dev.install: Don't install la-file (Policy 10.2)

osm-gps-map ships libtool la files in dev packages. They can simply be
removed since thay are not refered to from other packages.

See: http://wiki.debian.org/ReleaseGoals/LAFileRemoval
http://lists.debian.org/debian-devel/2009/08/msg00808.html
http://release.debian.org/~aba/la/current.txt

Thanks for considering the patch.


-- System Information:
Debian Release: squeeze/sid
  APT prefers natty
  APT policy: (500, 'natty')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-7-generic (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
diff -Nru osm-gps-map-0.7.2/debian/libosmgpsmap-dev.install osm-gps-map-0.7.2/debian/libosmgpsmap-dev.install
--- osm-gps-map-0.7.2/debian/libosmgpsmap-dev.install	2010-12-12 19:20:58.000000000 +0100
+++ osm-gps-map-0.7.2/debian/libosmgpsmap-dev.install	2011-04-07 14:02:22.000000000 +0200
@@ -2,4 +2,3 @@
 usr/lib/lib*.a
 usr/lib/lib*.so
 usr/lib/pkgconfig/*
-usr/lib/*.la

--- End Message ---
--- Begin Message ---
Source: osm-gps-map
Source-Version: 0.7.3-2

We believe that the bug you reported is fixed in the latest version of
osm-gps-map, which is due to be installed in the Debian FTP archive:

libosmgpsmap-dev_0.7.3-2_i386.deb
  to main/o/osm-gps-map/libosmgpsmap-dev_0.7.3-2_i386.deb
libosmgpsmap2-dbg_0.7.3-2_i386.deb
  to main/o/osm-gps-map/libosmgpsmap2-dbg_0.7.3-2_i386.deb
libosmgpsmap2_0.7.3-2_i386.deb
  to main/o/osm-gps-map/libosmgpsmap2_0.7.3-2_i386.deb
osm-gps-map_0.7.3-2.debian.tar.gz
  to main/o/osm-gps-map/osm-gps-map_0.7.3-2.debian.tar.gz
osm-gps-map_0.7.3-2.dsc
  to main/o/osm-gps-map/osm-gps-map_0.7.3-2.dsc
python-osmgpsmap_0.7.3-2_i386.deb
  to main/o/osm-gps-map/python-osmgpsmap_0.7.3-2_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 621...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
David Paleino <da...@debian.org> (supplier of updated osm-gps-map package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 27 Jun 2012 09:22:21 +0200
Source: osm-gps-map
Binary: libosmgpsmap-dev libosmgpsmap2 libosmgpsmap2-dbg python-osmgpsmap
Architecture: source i386
Version: 0.7.3-2
Distribution: unstable
Urgency: low
Maintainer: Debian OpenStreetMap Team <pkg-osm-maint@lists.alioth.debian.org>
Changed-By: David Paleino <da...@debian.org>
Description: 
 libosmgpsmap-dev - GTK+ library to embed OpenStreetMap maps - development files
 libosmgpsmap2 - GTK+ library to embed OpenStreetMap maps
 libosmgpsmap2-dbg - GTK+ library to embed OpenStreetMap maps - debugging 
symbols
 python-osmgpsmap - GTK+ library to embed OpenStreetMap maps - Python bindings
Closes: 621487
Changes: 
 osm-gps-map (0.7.3-2) unstable; urgency=low
 .
   * Don't install *.la files anymore (Closes: #621487)
   * Standards-Version bump to 3.9.3, no changes needed
   * debhelper compatibility bump to 9 (multi-arch)
   * Package switch from pysupport to dh_python2
   * Remove *.a and *.la from python extension
   * Updated debian/copyright
   * Added more files to debian/clean
   * Build with introspection disabled
   * Dropped python-osmgpsmap-dbg: all debugging symbols are now
     shipped in libosmgpsmap2-dbg.
   * Enable package hardening
Checksums-Sha1: 
 d3195efa2de1cf7bf93ad3308495d5c0f76aa8d6 1714 osm-gps-map_0.7.3-2.dsc
 ed4d309090fa6043ccab954dead22bb866e771fb 5680 osm-gps-map_0.7.3-2.debian.tar.gz
 7c715865cc267d80fdf43f42858334b9de812987 89806 
libosmgpsmap-dev_0.7.3-2_i386.deb
 411607399443df1d01fd1209ad0adea84174180b 42224 libosmgpsmap2_0.7.3-2_i386.deb
 0f54af1769d8a67f4033e72242f1e364bf77a109 15186 
libosmgpsmap2-dbg_0.7.3-2_i386.deb
 3e2a2a328edfc1058abc2f5da9650ad189895f46 42612 
python-osmgpsmap_0.7.3-2_i386.deb
Checksums-Sha256: 
 8bfeae5e0d01074fe0432dd4605f1ba971df0298faeb3decedf1c6455a8707f4 1714 
osm-gps-map_0.7.3-2.dsc
 cb4d082fac9450f93d9e8a0c0ffbcc063918afe49578a561e6d64c6045198ee2 5680 
osm-gps-map_0.7.3-2.debian.tar.gz
 eea00cbd9ccb1e63351049396c62e43303110682b2b5f47baf5881b0bed97d0a 89806 
libosmgpsmap-dev_0.7.3-2_i386.deb
 100ea005c46a4ad40410b8833f4c65a8921ecc37666a92138dd4ca5de75baf86 42224 
libosmgpsmap2_0.7.3-2_i386.deb
 490a307cbb343c9b5830934cec8f4aded5fb8086d73380369ea3485a18997f3a 15186 
libosmgpsmap2-dbg_0.7.3-2_i386.deb
 3b14efad2818d544a72289b0ba78966806a10bdea112d861bc19a0e6cf8242ca 42612 
python-osmgpsmap_0.7.3-2_i386.deb
Files: 
 2565db7ede00faa8e9dbb57587a03c0b 1714 libs optional osm-gps-map_0.7.3-2.dsc
 224c009564babd1c67486be06a5dd47a 5680 libs optional 
osm-gps-map_0.7.3-2.debian.tar.gz
 d2b980f786aef2fbd4c31024bc73fd45 89806 libdevel optional 
libosmgpsmap-dev_0.7.3-2_i386.deb
 c18fccd2a348e71ec90461510d08cf21 42224 libs optional 
libosmgpsmap2_0.7.3-2_i386.deb
 66e6908bf64ece8a6f3f96ab7b67d8db 15186 debug extra 
libosmgpsmap2-dbg_0.7.3-2_i386.deb
 e49989d3254d2778cd98bb40170b88d9 42612 python optional 
python-osmgpsmap_0.7.3-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk/qtpwACgkQ5qqQFxOSsXQ0NwCeOnfeUVHDlNvaZKnWy43mpcJ0
bwIAn0vg8UW3DLN7HSr8XfuVTcYxNfje
=I/KE
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-osm-maint mailing list
Pkg-osm-maint@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-osm-maint

Reply via email to