Package: josm
Version: 0.0.svn5267+dfsg1-1

Hello,

Le mercredi 4 janvier 2012 00:02:03, David Paleino a écrit :
> On Wed, 04 Jan 2012 00:08:56 +0300, Andrew O. Shadura wrote:
> > Currently, /usr/bin/josm wrapper script does the following:
> >   JAVA_OPTS="$JAVA_OPTS -Djava.net.preferIPv4Stack=true
> > 
> > -Djava.net.useSystemProxies=true"
> > 
> > This is wrong, IPv6 should be preferred, not IPv4. At any rate, this
> > can be configurable and not hard-coded in the wrapper script. Please
> > remove this setting.
> 
> That was done because Java was broken with "IPv6 preferred". So I'm not
> really doing this until I have a reasonably large number of people telling
> me that, with various network setups, removing -Djava.net.prefer* is safe.
> 

I also removed this option, and josm is still working correctly.
I've been using josm with an IPv4 only connection and with a dual IPv4/v6 
connection.

> So, you're the first :)

Second :-)


Regards,
Olivier


--- Package information. ---
Depends                              (Version) | Installed
==============================================-+-===========
openjdk-6-jre                                  | 6b24-1.11.3-2
 OR sun-java6-jre                              | 
 OR openjdk-7-jre                              | 
libcommons-codec-java                          | 1.6-1
libgettext-commons-java             (>= 0.9.6) | 0.9.6-2
libmetadata-extractor-java                     | 2.3.1+dfsg-2
liboauth-signpost-java                (>= 1.2) | 1.2.1.2-1
libsvgsalamander-java                          | 0~svn95-1
openstreetmap-map-icons-classic                | 1:0.0.svn27763-1
ant                                            | 1.8.2-4


Recommends            (Version) | Installed
===============================-+-===========
josm-plugins                    | 
webkit-image-gtk                | 
 OR webkit-image-qt             | 0.0.svn25399-3

_______________________________________________
Pkg-osm-maint mailing list
Pkg-osm-maint@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-osm-maint

Reply via email to