Your message dated Mon, 27 Jan 2014 11:00:23 +0000
with message-id <e1w7jvt-0008sl...@franck.debian.org>
and subject line Bug#734898: fixed in osm-gps-map 1.0.1-2
has caused the Debian Bug report #734898,
regarding libosmgpsmap-1.0-dev: fails to upgrade from 'sid' - trying to 
overwrite /usr/share/gtk-doc/html/osmgpsmap/up.png
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
734898: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=734898
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libosmgpsmap-1.0-dev
Version: 1.0.1-1
Severity: serious
User: debian...@lists.debian.org
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'sid' to 'experimental'.
It installed fine in 'sid', then the upgrade to 'experimental' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package libosmgpsmap-1.0-dev.
  Preparing to unpack .../libosmgpsmap-1.0-dev_1.0.1-1_amd64.deb ...
  Unpacking libosmgpsmap-1.0-dev (1.0.1-1) ...
  dpkg: error processing archive 
/var/cache/apt/archives/libosmgpsmap-1.0-dev_1.0.1-1_amd64.deb (--unpack):
   trying to overwrite '/usr/share/gtk-doc/html/osmgpsmap/up.png', which is 
also in package libosmgpsmap-dev 0.7.3-3
  Processing triggers for libglib2.0-0:amd64 (2.36.4-1) ...
  Processing triggers for fontconfig (2.11.0-2) ...
  Errors were encountered while processing:
   /var/cache/apt/archives/libosmgpsmap-1.0-dev_1.0.1-1_amd64.deb

Complete list of shared files:

  usr/share/gtk-doc/html/osmgpsmap/OsmGpsMap.html
  usr/share/gtk-doc/html/osmgpsmap/OsmGpsMapImage.html
  usr/share/gtk-doc/html/osmgpsmap/OsmGpsMapLayer.html
  usr/share/gtk-doc/html/osmgpsmap/OsmGpsMapPoint.html
  usr/share/gtk-doc/html/osmgpsmap/OsmGpsMapTrack.html
  usr/share/gtk-doc/html/osmgpsmap/annotation-glossary.html
  usr/share/gtk-doc/html/osmgpsmap/api-index-deprecated.html
  usr/share/gtk-doc/html/osmgpsmap/api-index-full.html
  usr/share/gtk-doc/html/osmgpsmap/api-reference-deprecated.html
  usr/share/gtk-doc/html/osmgpsmap/api-reference.html
  usr/share/gtk-doc/html/osmgpsmap/home.png
  usr/share/gtk-doc/html/osmgpsmap/index.html
  usr/share/gtk-doc/html/osmgpsmap/index.sgml
  usr/share/gtk-doc/html/osmgpsmap/left.png
  usr/share/gtk-doc/html/osmgpsmap/libosmgpsmap-OsmGpsMap-Deprecated.html
  usr/share/gtk-doc/html/osmgpsmap/libosmgpsmap.devhelp2
  usr/share/gtk-doc/html/osmgpsmap/right.png
  usr/share/gtk-doc/html/osmgpsmap/style.css
  usr/share/gtk-doc/html/osmgpsmap/up.png


cheers,

Andreas

Attachment: libosmgpsmap-dev=0.7.3-3_libosmgpsmap-1.0-dev=1.0.1-1.log.gz
Description: GNU Zip compressed data


--- End Message ---
--- Begin Message ---
Source: osm-gps-map
Source-Version: 1.0.1-2

We believe that the bug you reported is fixed in the latest version of
osm-gps-map, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 734...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Andreas Tille <ti...@debian.org> (supplier of updated osm-gps-map package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sat, 25 Jan 2014 23:42:11 +0100
Source: osm-gps-map
Binary: libosmgpsmap-1.0-0-dev libosmgpsmap-1.0-0 libosmgpsmap-1.0-0-dbg 
gir1.2-osmgpsmap-1.0
Architecture: source amd64
Version: 1.0.1-2
Distribution: unstable
Urgency: medium
Maintainer: Debian OpenStreetMap Team <pkg-osm-maint@lists.alioth.debian.org>
Changed-By: Andreas Tille <ti...@debian.org>
Description: 
 gir1.2-osmgpsmap-1.0 - GTK+ library to embed OpenStreetMap maps - Python 
bindings
 libosmgpsmap-1.0-0 - GTK+ library to embed OpenStreetMap maps
 libosmgpsmap-1.0-0-dbg - GTK+ library to embed OpenStreetMap maps - debugging 
symbols
 libosmgpsmap-1.0-0-dev - GTK+ library to embed OpenStreetMap maps - 
development files
Closes: 713635 732291 734898 735841
Changes: 
 osm-gps-map (1.0.1-2) unstable; urgency=medium
 .
   * Apply patch from Ross Gammon <rossgam...@mail.dk>
     Closes: #735841
   * Added myself to Uploaders
   * cme fix dpkg-control
   * debian/copyright: Fix license statement of files in src/*
     Closes: #732291
   * Add Breaks+Conflicts libosmgpsmap-dev
     Closes: #734898
   * Checked new upstream version and noticed that it
     Closes: #713635
   * debian/*.doc-base: long description
Checksums-Sha1: 
 6ae7397c7e9dcd2efeb7164615d409368f495f11 1782 osm-gps-map_1.0.1-2.dsc
 7593cbb4a2e7338474bad9b46ede71f9233e9312 75430 osm-gps-map_1.0.1.orig.tar.gz
 8c5dba6fc40a2e95a78ef418903ac7036756eb05 5556 osm-gps-map_1.0.1-2.debian.tar.xz
 9670f1f7b75300852a063b0d073e00829aedb07b 35974 
libosmgpsmap-1.0-0-dev_1.0.1-2_amd64.deb
 4351c7b1c965bae1f92a06261f4fe07bdc324fc3 33782 
libosmgpsmap-1.0-0_1.0.1-2_amd64.deb
 e29d503c4562975fb403a2d4f5ac3b48bdadfcf3 49148 
libosmgpsmap-1.0-0-dbg_1.0.1-2_amd64.deb
 d6442bc863701211281ea03a76b926bab299ca74 13580 
gir1.2-osmgpsmap-1.0_1.0.1-2_amd64.deb
Checksums-Sha256: 
 b72ad4ee462bd252356f2d14bd1caacd5f8ff20e9c9b4ba6477bbc8f3441e5c5 1782 
osm-gps-map_1.0.1-2.dsc
 3960172735c67f8e0cc7385b090eec0442966f1f819cefc59daab136c79a3b89 75430 
osm-gps-map_1.0.1.orig.tar.gz
 5ad1f30fa69c92cd3c3445841b318a5b057d8e2bb5a44edab5a0a9ad9fc9182a 5556 
osm-gps-map_1.0.1-2.debian.tar.xz
 6cb2b19fe9cdf32eee8347472072283cba15b991de52ae1b65765211119a5a0c 35974 
libosmgpsmap-1.0-0-dev_1.0.1-2_amd64.deb
 01b0e73997f27388fa9ae16686317f1783a7f7709d036f078e9bc869d2985452 33782 
libosmgpsmap-1.0-0_1.0.1-2_amd64.deb
 922a345505168a55ba44f5ef6ce00a240a16a0a02caea881a82b59c884cf688f 49148 
libosmgpsmap-1.0-0-dbg_1.0.1-2_amd64.deb
 71d1c160d057b4bbb3204d2d8db5f1d53681a02271284e7d4d75fff6202d57e9 13580 
gir1.2-osmgpsmap-1.0_1.0.1-2_amd64.deb
Files: 
 dd48a47b41d82a6a523417a8c9ad1b21 1782 libs optional osm-gps-map_1.0.1-2.dsc
 63fd089ac4d3b1cb489270de56d324d3 75430 libs optional 
osm-gps-map_1.0.1.orig.tar.gz
 f2019dc7e13e123d76fd779d8b028c2d 5556 libs optional 
osm-gps-map_1.0.1-2.debian.tar.xz
 896159ecaa6135d8c25425c9f2c45f92 35974 libdevel optional 
libosmgpsmap-1.0-0-dev_1.0.1-2_amd64.deb
 219a15d79f1279cefbfdacc51d995b76 33782 libs optional 
libosmgpsmap-1.0-0_1.0.1-2_amd64.deb
 1359850b1930e331b7a6f67ae3112976 49148 debug extra 
libosmgpsmap-1.0-0-dbg_1.0.1-2_amd64.deb
 18cae2b6300a0c1646c155860a785272 13580 introspection optional 
gir1.2-osmgpsmap-1.0_1.0.1-2_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlLk2u8ACgkQYDBbMcCf01pGZgCeOGTulB16DTiie+gBFA9BlbbX
GHQAn0i8vxFB/qnwrFNV305doYEJ64S3
=boXf
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-osm-maint mailing list
Pkg-osm-maint@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-osm-maint

Reply via email to