This is an automated email from the git hooks/post-receive script.

js pushed a commit to branch master
in repository libcpan-meta-check-perl.

commit 416f540ee7f6445ce7eb3559aa57d2a963598f57
Author: Jonas Smedegaard <d...@jones.dk>
Date:   Tue May 20 14:46:33 2014 +0200

    Update package relations: Tighten (build-)dependency on libcpan-meta-perl, 
and add fallback on (very) recent perl. (Favor recent perl and) tighten 
(build-)dependency on libcpan-meta-requirements-perl. Fix slightly relax perl 
version favored over libmodule-metatadata-perl. Fix stop build-depend 
explicitly on libtest-simple-perl: Version included with perl in recent enough 
even in oldstable.
---
 debian/rules | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/debian/rules b/debian/rules
index 3a6ad2f..f287f8f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,13 +27,12 @@ DEB_UPSTREAM_PACKAGE = CPAN-Meta-Check
 DEB_UPSTREAM_URL = http://www.cpan.org/authors/id/L/LE/LEONT
 
 # Needed by upstream build process and (always) at runtime
-deps = libcpan-meta-perl (>= 2.120920)
-deps +=, libcpan-meta-requirements-perl
-deps +=, perl (>= 5.14) | libmodule-metatadata-perl
+deps = libcpan-meta-perl (>= 2.132830) | perl (>= 5.19.5)
+deps +=, perl (>= 5.17.1) | libcpan-meta-requirements-perl (>= 2.121)
+deps +=, perl (>= 5.13.9) | libmodule-metatadata-perl
 
 # Needed by upstream testsuite
 deps-test = libtest-deep-perl
-deps-test +=, perl (>= 5.12) | libtest-simple-perl (>= 0.88)
 
 CDBS_BUILD_DEPENDS +=, $(deps), $(deps-test)
 CDBS_DEPENDS_$(pkg) = $(deps)

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libcpan-meta-check-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to