This is an automated email from the git hooks/post-receive script.

gregoa pushed a commit to branch master
in repository libsignatures-perl.

commit 9a3b43cf55360f4e41842e1e384cc7833408ce05
Author: gregor herrmann <gre...@debian.org>
Date:   Mon May 26 16:59:51 2014 +0200

    Imported Upstream version 0.09
---
 Changes                          |  3 +++
 META.json                        | 12 ++++++------
 META.yml                         | 12 ++++++------
 Makefile.PL                      | 10 +++++-----
 README                           |  2 +-
 README.md                        |  2 +-
 inc/ExtUtilsDepends.pm           |  2 +-
 lib/signatures.pm                |  8 ++++----
 t/00-report-prereqs.t            |  6 +++---
 xt/release/changes_has_content.t |  2 +-
 10 files changed, 31 insertions(+), 28 deletions(-)

diff --git a/Changes b/Changes
index 359105e..560860d 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,8 @@
 Revision history for signatures
 
+0.09      2014-05-25 16:17:38Z
+  - bump required version of B::Hooks::Parser for mswin32
+
 0.08      2014-05-24 05:07:22Z
   - Patch for perl > 5.19.2 by Peter Martini (RT#95181)
 
diff --git a/META.json b/META.json
index 98ccc1d..7745575 100644
--- a/META.json
+++ b/META.json
@@ -24,7 +24,7 @@
          "requires" : {
             "B::Hooks::OP::Check" : "0.17",
             "B::Hooks::OP::PPAddr" : "0.03",
-            "B::Hooks::Parser" : "0.07",
+            "B::Hooks::Parser" : "0.12",
             "ExtUtils::Depends" : "0.302"
          }
       },
@@ -32,7 +32,7 @@
          "requires" : {
             "B::Hooks::OP::Check" : "0.17",
             "B::Hooks::OP::PPAddr" : "0.03",
-            "B::Hooks::Parser" : "0.07",
+            "B::Hooks::Parser" : "0.12",
             "ExtUtils::Depends" : "0.302",
             "ExtUtils::MakeMaker" : "6.30"
          }
@@ -71,7 +71,7 @@
             "B::Hooks::EndOfScope" : "0.08",
             "B::Hooks::OP::Check" : "0.17",
             "B::Hooks::OP::PPAddr" : "0.03",
-            "B::Hooks::Parser" : "0.07",
+            "B::Hooks::Parser" : "0.12",
             "XSLoader" : "0",
             "perl" : "5.006",
             "strict" : "0",
@@ -97,7 +97,7 @@
    "provides" : {
       "signatures" : {
          "file" : "lib/signatures.pm",
-         "version" : "0.08"
+         "version" : "0.09"
       }
    },
    "release_status" : "stable",
@@ -113,7 +113,7 @@
          "web" : "https://github.com/karenetheridge/signatures";
       }
    },
-   "version" : "0.08",
+   "version" : "0.09",
    "x_Dist_Zilla" : {
       "perl" : {
          "version" : "5.019011"
@@ -720,7 +720,7 @@
                "Dist::Zilla::Plugin::Git::Tag" : {
                   "branch" : null,
                   "signed" : 0,
-                  "tag" : "v0.08",
+                  "tag" : "v0.09",
                   "tag_format" : "v%v%t",
                   "tag_message" : "v%v%t",
                   "time_zone" : "local"
diff --git a/META.yml b/META.yml
index 3e766a7..ab3c56e 100644
--- a/META.yml
+++ b/META.yml
@@ -5,7 +5,7 @@ author:
 build_requires:
   B::Hooks::OP::Check: '0.17'
   B::Hooks::OP::PPAddr: '0.03'
-  B::Hooks::Parser: '0.07'
+  B::Hooks::Parser: '0.12'
   ExtUtils::Depends: '0.302'
   ExtUtils::MakeMaker: '0'
   File::Spec::Functions: '0'
@@ -17,7 +17,7 @@ build_requires:
 configure_requires:
   B::Hooks::OP::Check: '0.17'
   B::Hooks::OP::PPAddr: '0.03'
-  B::Hooks::Parser: '0.07'
+  B::Hooks::Parser: '0.12'
   ExtUtils::Depends: '0.302'
   ExtUtils::MakeMaker: '6.30'
 dynamic_config: 0
@@ -34,12 +34,12 @@ no_index:
 provides:
   signatures:
     file: lib/signatures.pm
-    version: '0.08'
+    version: '0.09'
 requires:
   B::Hooks::EndOfScope: '0.08'
   B::Hooks::OP::Check: '0.17'
   B::Hooks::OP::PPAddr: '0.03'
-  B::Hooks::Parser: '0.07'
+  B::Hooks::Parser: '0.12'
   XSLoader: '0'
   perl: '5.006'
   strict: '0'
@@ -48,7 +48,7 @@ resources:
   bugtracker: https://rt.cpan.org/Public/Dist/Display.html?Name=signatures
   homepage: https://github.com/karenetheridge/signatures
   repository: https://github.com/karenetheridge/signatures.git
-version: '0.08'
+version: '0.09'
 x_Dist_Zilla:
   perl:
     version: '5.019011'
@@ -513,7 +513,7 @@ x_Dist_Zilla:
         Dist::Zilla::Plugin::Git::Tag:
           branch: ~
           signed: 0
-          tag: v0.08
+          tag: v0.09
           tag_format: v%v%t
           tag_message: v%v%t
           time_zone: local
diff --git a/Makefile.PL b/Makefile.PL
index 7b3e62d..a80883a 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -15,13 +15,13 @@ my %WriteMakefileArgs = (
   "BUILD_REQUIRES" => {
     "B::Hooks::OP::Check" => "0.17",
     "B::Hooks::OP::PPAddr" => "0.03",
-    "B::Hooks::Parser" => "0.07",
+    "B::Hooks::Parser" => "0.12",
     "ExtUtils::Depends" => "0.302"
   },
   "CONFIGURE_REQUIRES" => {
     "B::Hooks::OP::Check" => "0.17",
     "B::Hooks::OP::PPAddr" => "0.03",
-    "B::Hooks::Parser" => "0.07",
+    "B::Hooks::Parser" => "0.12",
     "ExtUtils::Depends" => "0.302",
     "ExtUtils::MakeMaker" => "6.30"
   },
@@ -33,7 +33,7 @@ my %WriteMakefileArgs = (
     "B::Hooks::EndOfScope" => "0.08",
     "B::Hooks::OP::Check" => "0.17",
     "B::Hooks::OP::PPAddr" => "0.03",
-    "B::Hooks::Parser" => "0.07",
+    "B::Hooks::Parser" => "0.12",
     "XSLoader" => 0,
     "strict" => 0,
     "warnings" => 0
@@ -47,7 +47,7 @@ my %WriteMakefileArgs = (
     "vars" => 0,
     "version" => 0
   },
-  "VERSION" => "0.08",
+  "VERSION" => "0.09",
   "test" => {
     "TESTS" => "t/*.t"
   }
@@ -71,7 +71,7 @@ my %FallbackPrereqs = (
   "B::Hooks::EndOfScope" => "0.08",
   "B::Hooks::OP::Check" => "0.17",
   "B::Hooks::OP::PPAddr" => "0.03",
-  "B::Hooks::Parser" => "0.07",
+  "B::Hooks::Parser" => "0.12",
   "ExtUtils::Depends" => "0.302",
   "ExtUtils::MakeMaker" => 0,
   "File::Spec::Functions" => 0,
diff --git a/README b/README
index fcc9c52..86c76b2 100644
--- a/README
+++ b/README
@@ -1,7 +1,7 @@
 
 
 This archive contains the distribution signatures,
-version 0.08:
+version 0.09:
 
   Subroutine signatures with no source filter
 
diff --git a/README.md b/README.md
index bf1e413..b8147a0 100644
--- a/README.md
+++ b/README.md
@@ -4,7 +4,7 @@ signatures - Subroutine signatures with no source filter
 
 # VERSION
 
-version 0.08
+version 0.09
 
 # SYNOPSIS
 
diff --git a/inc/ExtUtilsDepends.pm b/inc/ExtUtilsDepends.pm
index 6936acf..e9e78c5 100644
--- a/inc/ExtUtilsDepends.pm
+++ b/inc/ExtUtilsDepends.pm
@@ -24,7 +24,7 @@ sub register_prereqs {
         # minimum version that depends on ExtUtils::Depends 0.302
         'B::Hooks::OP::PPAddr' => '0.03',
         # minimum version that depends on ExtUtils::Depends 0.302
-        'B::Hooks::Parser' => '0.07',
+        'B::Hooks::Parser' => '0.12',
     # this is a workaround for a bug in [MakeMaker], where configure requires
     # prereqs are not added to the fallback hash
     ) foreach qw(configure build);
diff --git a/lib/signatures.pm b/lib/signatures.pm
index d93b5f8..7c73c78 100644
--- a/lib/signatures.pm
+++ b/lib/signatures.pm
@@ -4,12 +4,12 @@ package signatures;
 BEGIN {
   $signatures::AUTHORITY = 'cpan:FLORA';
 }
-# git description: v0.07-9-g5eecfaa
-$signatures::VERSION = '0.08';
+# git description: v0.08-1-g1cfbe5b
+$signatures::VERSION = '0.09';
 # ABSTRACT: Subroutine signatures with no source filter
 
 use XSLoader;
-use B::Hooks::Parser 0.07;
+use B::Hooks::Parser 0.12;
 use B::Hooks::OP::Check 0.17;
 use B::Hooks::OP::PPAddr;
 use B::Hooks::EndOfScope 0.08;
@@ -110,7 +110,7 @@ signatures - Subroutine signatures with no source filter
 
 =head1 VERSION
 
-version 0.08
+version 0.09
 
 =head1 SYNOPSIS
 
diff --git a/t/00-report-prereqs.t b/t/00-report-prereqs.t
index 1da6fb3..3a068d7 100644
--- a/t/00-report-prereqs.t
+++ b/t/00-report-prereqs.t
@@ -47,7 +47,7 @@ my $static_prereqs = do { my $x = {
                     'requires' => {
                                     'B::Hooks::OP::Check' => '0.17',
                                     'B::Hooks::OP::PPAddr' => '0.03',
-                                    'B::Hooks::Parser' => '0.07',
+                                    'B::Hooks::Parser' => '0.12',
                                     'ExtUtils::Depends' => '0.302'
                                   }
                   },
@@ -55,7 +55,7 @@ my $static_prereqs = do { my $x = {
                         'requires' => {
                                         'B::Hooks::OP::Check' => '0.17',
                                         'B::Hooks::OP::PPAddr' => '0.03',
-                                        'B::Hooks::Parser' => '0.07',
+                                        'B::Hooks::Parser' => '0.12',
                                         'ExtUtils::Depends' => '0.302',
                                         'ExtUtils::MakeMaker' => '6.30'
                                       }
@@ -94,7 +94,7 @@ my $static_prereqs = do { my $x = {
                                       'B::Hooks::EndOfScope' => '0.08',
                                       'B::Hooks::OP::Check' => '0.17',
                                       'B::Hooks::OP::PPAddr' => '0.03',
-                                      'B::Hooks::Parser' => '0.07',
+                                      'B::Hooks::Parser' => '0.12',
                                       'XSLoader' => '0',
                                       'perl' => '5.006',
                                       'strict' => '0',
diff --git a/xt/release/changes_has_content.t b/xt/release/changes_has_content.t
index 946ae11..c6710b2 100644
--- a/xt/release/changes_has_content.t
+++ b/xt/release/changes_has_content.t
@@ -4,7 +4,7 @@ use Test::More tests => 2;
 
 note 'Checking Changes';
 my $changes_file = 'Changes';
-my $newver = '0.08';
+my $newver = '0.09';
 my $trial_token = '-TRIAL';
 
 SKIP: {

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libsignatures-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to