This is an automated email from the git hooks/post-receive script.

xguimard-guest pushed a commit to branch master
in repository libapache-session-browseable-perl.

commit 754852f1dd36a2bdb2cf82779d618c344ab3133e
Author: Xavier Guimard <x.guim...@free.fr>
Date:   Wed Jul 6 06:44:49 2016 +0200

    Add patch to drop default warning since autopkgtest doesn't accept it
---
 debian/changelog                     | 33 +++------------------------------
 debian/patches/replace-warning.patch | 28 ++++++++++++++++++++++++++++
 debian/patches/series                |  1 +
 3 files changed, 32 insertions(+), 30 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 4ddf830..aab7ec3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,32 +1,4 @@
-libapache-session-browseable-perl (1.2.2-1) UNRELEASED; urgency=medium
-
-  TODO:
-  fix autopkgtest failure:
-
-    autopkgtest [11:39:11]: test command2: 
/usr/share/pkg-perl-autopkgtest/runner runtime-deps
-    autopkgtest [11:39:11]: test command2: [-----------------------
-
-    #   Failed test '/usr/bin/perl -w -M"Apache::Session::Browseable" -e 1 
2>&1 produced no output'
-    #   at /usr/share/pkg-perl-autopkgtest/runtime-deps.d/use.t line 75.
-    # Looks like you failed 1 test of 2.
-    /usr/share/pkg-perl-autopkgtest/runtime-deps.d/use.t .. 
-    1..2
-    # Use a sub module of Apache::Session::Browseable such as 
Apache::Session::Browseable::File
-    ok 1 - /usr/bin/perl -w -M"Apache::Session::Browseable" -e 1 2>&1 exited 
successfully
-    not ok 2 - /usr/bin/perl -w -M"Apache::Session::Browseable" -e 1 2>&1 
produced no output
-    Dubious, test returned 1 (wstat 256, 0x100)
-    Failed 1/2 subtests 
-
-    Test Summary Report
-    -------------------
-    /usr/share/pkg-perl-autopkgtest/runtime-deps.d/use.t (Wstat: 256 Tests: 2 
Failed: 1)
-      Failed test:  2
-      Non-zero exit status: 1
-    Files=1, Tests=2,  0 wallclock secs ( 0.02 usr  0.02 sys +  0.09 cusr  
0.00 csys =  0.13 CPU)
-    Result: FAIL
-    autopkgtest [11:39:11]: test command2: -----------------------]
-    autopkgtest [11:39:12]: test command2:  - - - - - - - - - - results - - - 
- - - - - - -
-    command2             FAIL non-zero exit status 1
+libapache-session-browseable-perl (1.2.2-1) unstable; urgency=medium
 
   [ Salvatore Bonaccorso ]
   * debian/control: Use HTTPS transport protocol for Vcs-Git URI
@@ -37,11 +9,12 @@ libapache-session-browseable-perl (1.2.2-1) UNRELEASED; 
urgency=medium
   * Add libjson-perl in dependencies
   * Bump Standards-Version to 3.9.8
   * Set debhelper compatibility to 9
+  * Add patch to prevent autopkgtest to fail
 
   [ gregor herrmann ]
   * debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
 
- -- Xavier Guimard <x.guim...@free.fr>  Sun, 03 Jul 2016 23:35:46 +0200
+ -- Xavier Guimard <x.guim...@free.fr>  Wed, 06 Jul 2016 06:43:09 +0200
 
 libapache-session-browseable-perl (1.1-1) unstable; urgency=medium
 
diff --git a/debian/patches/replace-warning.patch 
b/debian/patches/replace-warning.patch
new file mode 100644
index 0000000..788219d
--- /dev/null
+++ b/debian/patches/replace-warning.patch
@@ -0,0 +1,28 @@
+Description: Replace warning by doc entry
+ By default, Apache::Session::Browseable produces a warning that prevent users
+ that they have to use a sub module. Since autopkgtest doesn't accept any
+ output, this patch replaces this warning by a POD entry.
+Author: Xavier Guimard <x.guim...@free.fr>
+Forwarded: no
+Last-Update: 2016-07-06
+
+--- 
libapache-session-browseable-perl-1.2.2.orig/lib/Apache/Session/Browseable.pm
++++ libapache-session-browseable-perl-1.2.2/lib/Apache/Session/Browseable.pm
+@@ -2,8 +2,6 @@ package Apache::Session::Browseable;
+ 
+ our $VERSION = '1.2.2';
+ 
+-print STDERR "Use a sub module of Apache::Session::Browseable such as 
Apache::Session::Browseable::File";
+-
+ 1;
+ __END__
+ 
+@@ -11,6 +9,8 @@ __END__
+ 
+ Apache::Session::Browseable - Add index and search methods to Apache::Session
+ 
++Use a sub module of Apache::Session::Browseable such as 
Apache::Session::Browseable::File
++
+ =head1 SYNOPSIS
+ 
+   use Apache::Session::Browseable::MySQL;
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ad395bd
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+replace-warning.patch

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libapache-session-browseable-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to