This is an automated email from the git hooks/post-receive script.

carnil pushed a change to annotated tag upstream/0.37
in repository libpath-class-perl.

        at  4978f59   (tag)
   tagging  25403f11168abb67408e4635ecdd9030f4822809 (commit)
  replaces  upstream/0.36
 tagged by  Salvatore Bonaccorso
        on  Sun Aug 14 06:43:57 2016 +0200

- Log -----------------------------------------------------------------
Upstream version 0.37

Andrew Gregory (2):
      t/03-filesystem.t: always set :raw for spew_lines
      always use canonpath on arguments to splitdir

Aran Deltac (1):
      new spew() method that does the inverse of the slurp() method.

Dagfinn Ilmari Mannsåker (1):
      Don't convert file into directory in subsumes()

Dave Rolsky (8):
      Use travis-perl/helpers to test with blead and 5.8
      Merge pull request #35 from kenahoo/autarch/travis-tests-5.8
      Check all print calls in spew and explicitly call (and check) close
      Add 5.22 to build targets and use Travis containers
      Add aspell package, add dev perl, allow blead failures, add coverage, use 
travis-perl --auto
      Include aspell-en package for .travis.yml
      Quote Perl versions so 5.20 is not interpreted as 5.2
      Test with Perl 5.24

David Golden (3):
      Use internal guts when constructing Dirs from Dirs
      stringify variables passed to canonpath
      Fix bug with leading empty string - became unintentional UNC path on

David Precious (3):
      Link to other module's POD.
      More POD linkage.
      POD linkage here too.

Fabrice Gabolde (1):
      Document 'basename' method for directories.

Karen Etheridge (2):
      include the filename in the error message for resolve()
      new shortcut opena(), to open a file for appending.

Ken Williams (296):
      Coded and documented
      Basic tests
      Coded and documented
      Tests from File::Spec, handy to look at
      *** empty log message ***
      Coded and documented
      Superclass for files and dirs
      Inherit from Path::Class::Entity.
      Don't mention Path::Class::System
      Might not be used, but check in anyway
      *** empty log message ***
      *** empty log message ***
      Fix typo in docs
      Hide all File::Spec calls behind a _spec() method
      Preliminary tests
      Need File::Spec::Mac version 1.3 to work properly
      *** empty log message ***
      add support for foreign paths
      Add more tests for foreign paths
      Add docs for new foreign support
      inherit foreign properties of cloned object
      Improve support & docs for foreign paths
      *** empty log message ***
      Version bump to 0.02
      *** empty log message ***
      *** empty log message ***
      Fake out File::Spec properly to think it's on Unix
      *** empty log message ***
      Version bump
      Rewrite general description docs
      *** empty log message ***
      Add to CVS
      Basic interfaces for interacting with filesystem
      Add some basic filesystem interaction via core modules
      Autogenerated from Build.PL now
      Generate a Makefile.PL
      *** empty log message ***
      *** empty log message ***
      Add license
      Test out the next() method
      Add next() and is_dir()
      Add is_dir()
      *** empty log message ***
      Clean up the mess
      *** empty log message ***
      Version bump
      Remove weird is_dir() method
      Add dependencies
      Add prereqs
      Call stringify() explicitly, which fixes a couple bugs on 5.6.0
      *** empty log message ***
      *** empty log message ***
      Fix a testing bug under Win32
      Export file() and dir() by default
      *** empty log message ***
      file() and dir() are now exported by default
      *** empty log message ***
      Small doc patch
      Version bump
      *** empty log message ***
      No need to use File::Spec here
      Explicitly call stringify() when we want to stringify.
      Add docs for the filesystem interaction methods
      *** empty log message ***
      *** empty log message ***
      *** empty log message ***
      Added a parent() method, equivalent to dir().
      *** empty log message ***
      Test the File->parent() method
      Add a basename() method to
      Version bump to 0.05
      *** empty log message ***
      Update my email address
      *** empty log message ***
      This isn't used anywhere
      *** empty log message ***
      *** empty log message ***
      A little more anal probing
      Add some docs for next() and simplify a part of its code
      Version bump
      *** empty log message ***
      Added slurp(), openr(), and openw()
      Clean up after slurp test
      *** empty log message ***
      *** empty log message ***
      Make sure dir('foo/')->parent works
      Fix dir('foo/')->parent
      *** empty log message ***
      Version bump
      *** empty log message ***
      Cryptographically sign the distribution
      *** empty log message ***
      Add copyright statement
      Version bump
      Create a README
      *** empty log message ***
      Use Carp::croak() instead of die() in next(), and document the thrown 
      *** empty log message ***
      Add the dir_list() method.
      Add tests for dir_list() and fix its bugs
      Simplify new() a bit
      Document dir_list() and allow for negative LENGTH
      Test negative LENGTH argument for dir_list()
      Fix a double-backslash bug for Win32 paths
      *** empty log message ***
      Add the is_dir() method
      Version bump
      *** empty log message ***
      Use a modern File::Spec
      *** empty log message ***
      Fix doc typo
      Fix a relative() bug
      Version bump
      *** empty log message ***
      Fix doc bug for open()
      Version bump
      Improve semantics for dir_list() in scalar context
      *** empty log message ***
      Move stat() and lstat() to
      Require version 0.87 of File::Spec
      Add chomping to slurp
      *** empty log message ***
      Add the remove() method
      Add notes about cross-platform usage
      Add a remove() method
      This VMS special-casing somehow got put in the wrong place
      *** empty log message ***
      Use an extension on filenames, so they work on VMS
      Fix doc typos
      Use remove()
      Add a subsumes() method to Dir
      Version bump
      Don't track in CVS
      *** empty log message ***
      *** empty log message ***
      Add touch()
      Let's use Test::More
      Add children() and recurse()
      Update the children() docs
      Version bump
      *** empty log message ***
      Silence a warning in subsumes()
      Fix dir()->absolute->relative
      Version bump
      *** empty log message ***
      Version bump
      fix subsumes('/', '/foo')
      Version bump
      *** empty log message ***
      Fix a typo
      Little optimization
      Add contains() method
      Make subsumes() respect foreignness of its arguments
      Some TODO tests for translating paths from MacOS to Unix
      Version bump
      * for version 0.16
      We want blib, not blibdirs
      Add a failing test for directories called '0'
      Get rid of exists() on array
      Make sure all objects are boolean true
      Add is_relative() method
      Add a resolve() method
      Add is_relative() test
      Fix doc errors for resolve()
      Need to use Cwd
      Use temp files/directories in tests
      Make dir(undef) return undef
      Comment out the TODO tests, because people tend to think they're 
failures. =(
      commit 99bdc62021896ea3a96ac1a2d19e40eebbe9a74e
      commit 72457a962629537d79abe3e28d38188354ed2dab
      commit 9b54407f708b882502ca69f2a541a67397f91a7d
      Version bump
      commit 56f11bb11cf1082b612971befdbfc5717af31c14
      Fix my email address
      Fix 0/0.0 bug in children()
      Version bump
      commit 567cfce2be8e2c8dcff0486bd144b07b9ba5db40
      POD fix for is_relative()
      Add no_hidden parameter for children()
      commit ac52342335058cf9c32f7891c9ef736ac4944143
      Add _is_local_dot_dir() private method
      Fix symlink problem for CWD in tests
      commit 1737ce428735b215bb3349c9122f0835b8b27ded
      Add file_class() and dir_class() methods
      Bump version to 0.19
      Add t/04-subclass.t to MANIFEST
      croak() instead of die() for openr/openw
      Apply patch from Graham for iolayers in slurp()
      Change slurp()'s 'iolayers' to 'iomode', and change docs accordingly.
      Adjust tests for API tweak to 'iomode'
      Version bump
      Oops, a little ahead of myself.
      Spelling fixes
      Skip io layer testing under 5.6
      Version bump
      Add basename() for directory objects
      Start switching to Dist::Zilla
      roll a release
      More adjustments for Dist::Zilla
      More Dist::Zilla stuff
      Use [@Basic] instead of the bunch of modules I was using
      let dzil create Build.PL
      We don't actually want this.
      Let dzil handle the prereq lists
      Fix resolve() error message on file that doesn't exist
      Add File::Temp interface
      Doc tweaks
      Version bump
      Version bump
      Add auto-tagging
      fix grammar error
      For using Dist::Zilla
      Switch to current version of plugin
      Don't need these 2 files anymore
      let dzil create the INSTALL file
      add an fmap_cont() method, which we'll rename soon
      Change method name to traverse().
      Switch to Git tagging
      Tests for traverse()
      Some files to ignore
      resolve() now croak()s instead of die()s on non-existent file. [Danijel 
      Version bump
      Merge pull request #2 from karenetheridge/master
      Merge pull request #3 from karenetheridge/master
      Merge pull request #4 from bluefeet/master
      Update format of files, I find this more readable
      Fix pod typo
      Version bump for release
      Merge pull request #5 from cho45/tempdir
      Changes entry for tempdir()
      Merge pull request #6 from fgabolde/master
      Change language for basename() docs
      Merge pull request #8 from Mekk/traverse_if
      Merge pull request #9 from Mekk/recurse_prune
      traverse_if() to Changes
      Add summaries
      Remove diagnostic output in test
      Remove method prototype
      Merge pull request #11 from bigpresh/pod_links
      Changelog for previous commit
      Version bump
      Fix misleading variable names in docs.  See .
      Fix failing traverse_if tests when running as root
      Merge pull request #7 from Smylers/master
      Add components() method
      Fix w32 test failures in 07-recurseprune.t
      Add date to release
      Version bump
      Merge pull request #13 from rwstauner/master
      Implement (a variant of) Yanick's 'split' parameter for the slurp() method
      Fix grammar error in docs. [Karen Etheridge]
      Ignore build directories
      Prepare for release - write 'Changes' file & bump version
      Add a README for github
      Add date to Changes
      Update dependency on File::Spec to 3.26, fixing RT #83143.
      Merge pull request #17 from oalders/master
      Latest Changes additions
      Version bump
      Add historical note
      Merge pull request #19 from dolmen/use-parent
      We export file() and dir() by default
      Catch up the changelog
      Implement copy() and move() methods
      Remove unneeded File::Spec load, clean up a temp file
      Add tests for copy() and move()
      Merge pull request #21 from robrwo/cp_mv
      Merge pull request #22 from robrwo/cp_mv
      As advised in the utime() docs, pass undef as the time for touch()
      Merge branch 'cp_mv'
      Update CHANGES for a release
      Change bugtracker to github's
      Add the Travis CI plugin
      See whether this extra travis stuff helps
      Merge pull request #25 from robrwo/cp-mv-pod-fixes
      Merge pull request #26 from ilmari/fix-subsumes-file
      Version bump
      Try again to get TravisCI working.
      See whether THIS stuff (expand @Basic to feed param to GatherDir) gets 
Travis working.
      I think the travis.yml version numbers are supposed to be strings.
      Update Changes for release
      Merge pull request #31 from andrewgregory/win_spew_lines
      Version bump
      Merge pull request #34 from maxmind/master
      Merge pull request #37 from sergeyromanov/patch-1
      Merge pull request #39 from viviparous/master
      Bump version & add Changes entry
      Merge pull request #42 from dolmen/lazy-load-File-Copy
      Fix Carp::Croak to Carp::croak
      Add some fixes & tests for contains() with updir stuff (github #43)
      Merge pull request #44 from mzrinsky/patch-1
      Merge pull request #45 from andrewgregory/trailing-slash
      Update Changes file for release
      Merge pull request #48 from nrdvana/master
      Version bump

Marcin Kasperski (3):
      Added traverse_if function - traverse which allows one
      Added pruning support in dir->recurse. If recurse callback
      Changed value of PRUNE constant to the one much less likely to happen by 

Michael Conrad (4):
      Add additional test cases for contains and subsumes
      Handle case where $other evaluates false
      Fix "contains" when $self is a relative path - #43
      Doc update for contains/subsumes

Olaf Alders (1):
      Fixes "Unterminated C<...> sequence" in Pod

Olivier Mengué (3):
      use base -> use parent
      Update 'Changes'
      Lazy load File::Copy and Perl::OSType

Randy Stauner (1):
      Replace unicode MINUS SIGN with ascii HYPHEN-MINUS

Robert Rothenberg (8):
      Renamed copy and move to copy_to and move_to
      Added stub POD for copy_to and move_to
      Renamed copy/move to copy_to/move_to
      copy_to returns a Path::Class::File object
      move_to updates the object
      Stringify destination for move_to method
      Stringify destination for copy_to method
      Updated POD for copy_to and move_to methods

Salvatore Bonaccorso (2):
      Fix spelling error in POD
      Imported Upstream version 0.37

Smylers (2):
      Document opena
      openw doc error fix

William Stevenson (1):
      spew_lines with test

cho45 (2):
      add new `tempdir` function to Path::Class which returns new 
Path::Class::Dir instance pointed to temporary directory.
      add doc for tempdir.

mzrinsky (1):

user0 (1):
      use croak instead of die; use eval syntax instead of universal::isa (as 
perlcritic wishes)

Сергей Романов (1):
      Fix Pod typos


No new revisions were added by this update.

Alioth's /usr/local/bin/git-commit-notice on 

Pkg-perl-cvs-commits mailing list

Reply via email to