This is an automated email from the git hooks/post-receive script.

gregoa pushed a commit to branch master
in repository libperl-apireference-perl.

commit ed3a81d93b51be2a150ea6c4015d690ae16f5f1d
Author: gregor herrmann <gre...@debian.org>
Date:   Mon Sep 26 21:50:53 2016 +0200

    Add support for 5.24.1.
    
    Closes: #838934
---
 data/perlapi.5.24.1.pod.xz     | Bin 0 -> 79420 bytes
 debian/clean                   |   1 +
 debian/patches/5.24.1.patch    |  34 ++++++++++++++++++++++++++++++++++
 debian/patches/series          |   1 +
 debian/source/include-binaries |   1 +
 5 files changed, 37 insertions(+)

diff --git a/data/perlapi.5.24.1.pod.xz b/data/perlapi.5.24.1.pod.xz
new file mode 100644
index 0000000..cc1ed98
Binary files /dev/null and b/data/perlapi.5.24.1.pod.xz differ
diff --git a/debian/clean b/debian/clean
index 8a00725..593485f 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1,2 +1,3 @@
 lib/Perl/APIReference/V5_022_002.pm
 lib/Perl/APIReference/V5_024_000.pm
+lib/Perl/APIReference/V5_024_001.pm
diff --git a/debian/patches/5.24.1.patch b/debian/patches/5.24.1.patch
new file mode 100644
index 0000000..45a6149
--- /dev/null
+++ b/debian/patches/5.24.1.patch
@@ -0,0 +1,34 @@
+Description: add support for 5.24.1
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/838934
+Author: gregor herrmann <gre...@debian.org>
+Last-Update: 2016-09-26
+Forwarded: https://rt.cpan.org/Ticket/Display.html?id=118092
+Bug: https://rt.cpan.org/Ticket/Display.html?id=118092
+
+--- a/lib/Perl/APIReference.pm
++++ b/lib/Perl/APIReference.pm
+@@ -18,10 +18,11 @@
+ 
+ sub _par_loader_hint {
+   require Perl::APIReference::Generator;
+-  require Perl::APIReference::V5_024_000;
++  require Perl::APIReference::V5_024_001;
+ }
+ 
+ our %Perls = (
++  5.024001 => 'V5_024_001',
+   5.024000 => 'V5_024_000',
+   5.022002 => 'V5_022_002',
+   5.022001 => 'V5_022_001',
+@@ -64,8 +65,8 @@
+   5.006    => 'V5_006_000',
+ );
+ 
+-our $NewestAPI       = '5.024000';
+-our $NewestStableAPI = '5.024000';
++our $NewestAPI       = '5.024001';
++our $NewestStableAPI = '5.024001';
+ 
+ $Perls{'5.024000'} = $Perls{5.024};
+ $Perls{'5.022000'} = $Perls{5.022};
diff --git a/debian/patches/series b/debian/patches/series
index 37a2db9..d2a7f68 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
 5.22.2.patch
 5.24.0.patch
+5.24.1.patch
diff --git a/debian/source/include-binaries b/debian/source/include-binaries
index 3f8d976..6f3d248 100644
--- a/debian/source/include-binaries
+++ b/debian/source/include-binaries
@@ -1,2 +1,3 @@
 data/perlapi.5.22.2.pod.xz
 data/perlapi.5.24.0.pod.xz
+data/perlapi.5.24.1.pod.xz

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libperl-apireference-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to