This is an automated email from the git hooks/post-receive script.

angel pushed a change to annotated tag upstream/1.1.82
in repository librinci-perl.

        at  0869ffd   (tag)
   tagging  6f2519cee629edb54b63c51883d2c38660a6aaa1 (commit)
  replaces  upstream/1.1.81
 tagged by  Angel Abad
        on  Thu Dec 15 13:52:12 2016 +0100

- Log -----------------------------------------------------------------
Upstream version 1.1.82


Angel Abad (1):
      New upstream version 1.1.82

Steven Haryanto (on Asus EEEPC) (8):
      Fix POD error
      Remove arg spec key 'src', I don't think it's general enough
      Release v1.1.21
      Rename unready module
      Deprecate undo protocol; Rewrite transaction specification (clarify steps 
in more detail, add examples)
      Release v1.1.24
      Update Changes

Steven Haryanto (on Asus Zenbook) (47):
      Fix terminology in Changes
      function: result property: add key 'statuses'
      Release v1.1.32
      Move comments from periwrap
      POD fmt
      Rename entity_version to entity_v
      Release v1.1.36
      Replace references to Perinci::Access::InProcess to ::Perl
      result: Replace error_stack with prev
      Release v1.1.37
      Add result metadata: logs
      Add stack_trace to create log
      Rename pkg to package in create log
      Release v1.1.38
      Code of argument's cmdline alias gets option value
      dist: dzil: Force @SHARYANTO version (inspired by chorny)
      function: examples: Introduce 'src' and 'src_plang' properties so that 
examples can also be more general
      Release v1.1.39
      dist: Add personal note in Changes
      dist: dzil: rename bundle SHARYANTO -> Author::SHARYANTO
      dist: pw: rename bundle SHARYANTO -> Author::SHARYANTO
      dist: Remove homepage/repository (become default with pwp-sh 0.05+)
      Add result metadata property: func.*
      Release v1.1.40
      Update example name
      completion routine will be called with word=>... and ci=>... only
      Add argument spec's 'default' and 'element_completion' properties
      Release v1.1.42
      Specify argument property: cmdline_on_getopt
      Specify argument property: cmdline_on_getarg
      Release v1.1.43
      Revert "Specify argument property: cmdline_on_getarg"
      Update Changes
      Update Changes
      dist: Replace MANIFEST.SKIP with DZP::PruneFiles
      Add Sah::Schema::Rinci
      Release v1.1.45
      Tweak schema: cmdline_aliases' properties were not defined
      Forgot to add x (defhash properties) in several places
      Release v1.1.45
      Release v1.1.46
      Revert "Rename args_as to args/as, result_naked to result/is_naked to 
make top-level properties cleaner"
      Release v1.1.50

Steven Haryanto (on PC) (101):
      Change 'set' alias spec (back) to 'code' (backward compatibility)
      Release v1.1.9
      Add 'schema' alias spec
      Release v1.1.10
      function: Add feature: immutable
      Rename pkg_version to entity_version, becomes a general property
      Release v1.1.11
      Add Rinci::result
      Release v1.1.12
      Specify tag metadata
      Release v1.1.13
      Change 'exec' dep clause to 'prog' (it's a better name and does not imply 
that we need to execute the program, there can be other dependency for that)
      Release v1.1.14
      Update Sah schema syntax
      Release v1.1.15
      Rewrite undo protocol section: provide summary, describe 
benefits/drawbacks, change example. I want to it to be clearer, preparing the 
section on undo/transaction manager
      Revise undo documentation again, declare dep clause 'undo_storage'
      Release v1.1.16
      Mention status 430 (transaction is not supported for this request)
      Mention status 431 (transaction is aborted)
      Change transaction-related status codes (430->431, 431->432, new 434)
      Set status 531 & 532
      Introduce status codes 433, 435
      English grammar
      Revise status codes (432 & 433 -> 432)
      pod: Terminology (property instead of key)
      Split undo protocol section to its own document; specify undo/redo under 
transaction; specify features tx & idempotent
      Tutorial does not belong in spec, should put it in implementation dist 
(like Perinci)
      tx feature becomes a hash
      Some revision, add detailed do/rollback/undo/redo/recovery steps 
      Release v1.1.17
      Add FAQ entry
      Some adjustments (from implementation)
      Update transaction feature spec: required -> req, mention link to 
      Refine undo/redo mechanism (special argument -tx_call_id, record_step -> 
record_undo_step / record_redo_step)
      Change undo_storage dep to trash_dir, tmp_dir (relevant even for 
non-undo-related tasks), undo_trash_dir
      Release v1.1.18
      Fix link
      A bit of rewording
      Add status code: 429 (too many requests)
      Adjust transaction statuses (transient states now in lowercase: [iaude], 
final states in uppercase: [CRUX])
      Release v1.1.19
      Update links to module
      Add argument specification key: src, cmdline_src
      Add TODO
      Release v1.1.20
      Define -undo_action = check; define requirements of undoable function
      Update Changes
      Remove -check_action => check (unnecessary, all undoable function's 
actions MUST BE undoable), add a section to explain about non-undoable actions
      Replace link
      dzil: Add weaver.ini (include Changes)
      dzil: exclude adding Changes to
      Add FAQ entry: drawback
      Describe ordering of steps/calls during undo/rollback; remove txm's 
get_undo_steps() and get_redo_steps(), function gets steps from -undo_data 
instead, like in non-transactional mode
      Release v1.1.22
      Major rewrite of transaction specification
      Release v1.1.23
      Fix argument passing style
      Remove use=>1 in tx feature (redundant)
      Release v1.1.25
      Remove old reference to use=>1 property in tx feature
      Specify savepoint
      Specify release savepoint
      Add FAQ entry on non-undoable action
      Term change: call -> action
      Release v1.1.26
      Link to HTTP RFC, mark codes that are introduced by Rinci
      Introduce status code 331 (confirmation required)
      Confirmation prompt can also simply be given in message ($res->[1])
      Rename old references to Sub::Spec:: modules
      Release v1.1.27
      ritx: To link between check_state and fix_state, now we use -tx_action_id 
=> GUID instead of passing -tx_undo_actions, because the later is already 
recorded in database by the time of fix_state, and we shouldn't modify it anyway
      Release v1.1.28
      Use standard UUID/GUID representation (implied)
      Specify that result message should contain a description of what needs to 
be fixed, or how it is already fixed, or how it is unfixable; the message can 
then be logged by TM to be displayed to user
      Release v1.1.29 is actually used (steven--)
      Release v1.1.30
      dzil: Remove Changes podweaver plugin (I changed my mind, it's not a good 
idea :) )
      Update link to Sah spec (now split)
      Base on DefHash
      Release v1.1.31
      Define result metadata: error_stack
      Split Rinci::Schema to its own dist
      Release v1.1.33
      Introduce status 44x and 54x (experimental)
      Release v1.1.34
      Update weaver.ini to use PWP::SHARYANTO
      Add rfc 2119 incantation
      Introduce property 'x' (from DefHash 1.0.3)
      Release v1.1.35
      Mark todo-rebuild-with-makemaker
      dist: Rename .todo tag file
      dist: Rename .todo tag file (put reason into why I need to re-release 
this dist)
      Replace references to Perinci::BashComplete to Perinci::Sub::Complete 
(its replacement)
      Wording on 'cmdline_src', define 'file' as another valid value of 
      Add property 'test' to function example spec
      Release v1.1.41

Steven Haryanto (on PC, Bandung) (7):
      dist: Add # DATE
      Release v1.1.44
      Tweak schema
      Make sure all defhash props are added
      Release v1.1.47
      Allow completion routine to return hash (completion reply + metadata) 
instead of just array (completion reply), as already implemented in 
Perinci::Sub::Complete and Complete::Util
      Release v1.1.52

Steven Haryanto (on PC, Jakarta) (10):
      dist: Add tags
      Specify two new function dependency: pkg & func
      Release v1.1.48
      Checking dep func/pkg should be done using Riap info action and not meta
      Update Sah schema
      Rename args_as to args/as, result_naked to result/is_naked to make 
top-level properties cleaner
      Release v1.1.49
      Tweak Sah schema: add entity_date
      Release v1.1.51
      [dist] Change dzil/pw plugin bundle

perlancar (@netbook-zenbook) (33):
      POD tweaks (explain 1xx, mark with * some status codes which haven't been 
      Add FAQ document
      POD Wording, update examples
      Add result metadata property: perm_err
      Release v1.1.54
      Add tag: name-id
      [dist] Rename tag
      Introduce is_flag bool property on command-line alias
      Release v1.1.57
      Rename Rinci::result -> Rinci::resmeta
      Release v1.1.58
      Hackety hack
      Add example for partial_res
      Release v1.1.64
      Add more detailed note in Changes
      Specify that streaming input and output now uses coderef instead of 
      Release v1.1.71
      Edit Changes
      Specify argument specification property 'deps', to allow an argument to 
depend on others
      Introduce function property 'args_groups' to allow things like requiring 
{only one,all} members of a group of args must be specified (and possibly 
others in the future)
      Release v1.1.72
      Forgot to update schema
      Release v1.1.73
      [Incompatible change] Use DefHash's 'caption' property for link title, 
instead of using another ('title')
      Update schema
      Add (experimental) argument specification: filters
      Release v1.1.75
      Typos (args_rels, not args_schema) & wording
      Release v1.1.77
      Adjust to Sah 0.9.36 (renamed dep_one -> dep_any, req_dep_one -> 
      [dzil] Update syntax of lint-prereqs directive (-> lint_prereqs) to be 
more IOD-compliant
      Tweak example to show what cmdline_alias code receives

perlancar (@netbook-zenbook-ux305) (4):
      Follow Sah-Schemas convention (individual Sah schemas are put into their 
separate Sah::Schema::* package), Sah schemas are now put in 
Sah::Schema::rinci::* modules
      Release v1.1.80
      Introduce argument spec property 'index_completion'
      Release v1.1.82

perlancar (@pc-home) (3):
      Update some module mentions
      Split Sah schemas to Sah-Schemas-Rinci so that schema tweaks don't 
require releasing a new spec release

perlancar (@pc-office) (53):
      Introduce function argument spec properties: cmdline_prompt, is_password
      Release v1.1.53
      Introduce argument submetadata (experimental)
      Release v1.1.55
      Introduce argument element submetadata (element_meta property in argument 
specification, experimental)
      Release v1.1.56
      Introduce 'encoding' property in result metadata and argument 
      Rename file
      Introduce 'arg_errors' and 'arg_warnings' properties in result metadata
      Introduce 'check_arg' feature and '-action' special argument
      Release v1.1.59
      Forgot to update Sah schema
      Release v1.1.60
      Introduce 'encoding' property in result specification
      Release v1.1.61
      Give more explanation in Changes
      Cancel adding support for 'encoding', will be handled on the Riap level
      Release v1.1.62
      Add statuses 201, 204
      Introduce status 207, replace arg_errors & arg_warnings with the more 
generic 'results' result metadata property to report per-item/detailed statuses
      Release v1.1.63
      Hackety hack
      [Bugfix] Forgot to update Sah schema
      Release v1.1.65
      Make it clear that there should be at most one argument with partial=1
      Update Changes
      Release v1.1.66
      Tweaks to partial arg/result, introduce stream input (arg) & output 
(result), add FAQ items
      Release v1.1.67
      Forgot to mention 'stream' argument spec property
      Release v1.1.68
      [Bugfix] forgot to update Sah schema
      Release v1.1.69
      Replace copy-pasted text
      Add FAQ items
      Add 'links' property to arg spec
      Release v1.1.70
      [doc] Add UPDATE entry for older entries in Changes which have been 
      func: Introduce another value for 'cmdline_src' argument spec property: 
'stdin_or_file' (in addition to 'stdin_or_files')
      Release v1.1.74
      Replace function property args_groups with args_schema
      Release v1.1.76
      [dist] Move spec prereqs from RuntimeRequires to DevelopRecommends to 
reduce deps but still allow indicating spec requirement
      Release v1.1.78
      Define new command-line source for function argument (cmdline_src): 
      [dist] Re-pass lint-prereqs (core modules must now be listed)
      Release v1.1.79
      [dist] Use Pod::Weaver::Plugin::Sah::Schema
      [dist] Add nytprof* to .gitignore
      [dist] Re-pass lint-prereqs
      Release v1.1.81
      Remove DZP: & PWP:Sah::Schemas
      Typo [RT#118381]


No new revisions were added by this update.

Alioth's /usr/local/bin/git-commit-notice on 

Pkg-perl-cvs-commits mailing list

Reply via email to