This is an automated email from the git hooks/post-receive script.

js pushed a commit to annotated tag v0.08
in repository libdancer-plugin-rest-perl.

commit 4402b7217d71df5bbdea094af2f95283e5f50bcc
Author: Yanick Champoux <yan...@babyl.dyndns.org>
Date:   Thu Mar 6 19:59:19 2014 -0500

    dzil the distro
---
 .gitignore                |  2 ++
 .mailmap                  |  2 ++
 CHANGES                   | 42 ----------------------------------------
 Changes                   | 38 ++++++++++++++++++++++++++++++++++++
 MANIFEST                  | 20 +++++++++++++++----
 MANIFEST.SKIP             |  2 ++
 Makefile.PL               | 49 -----------------------------------------------
 dist.ini                  | 11 +++++++++++
 lib/Dancer/Plugin/REST.pm |  9 ++-------
 9 files changed, 73 insertions(+), 102 deletions(-)

diff --git a/.gitignore b/.gitignore
index e5bf2f6..dc7306c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
+Dancer-Plugin-REST*
+.build
 pm_to_blib
 t/logs
 *.old
diff --git a/.mailmap b/.mailmap
new file mode 100644
index 0000000..fe63808
--- /dev/null
+++ b/.mailmap
@@ -0,0 +1,2 @@
+Alexis Sukrieh <suk...@sukria.net> <ale...@weborama.com>
+Franck Cuny <fran...@cpan.org> <fra...@lumberjaph.net>
diff --git a/CHANGES b/CHANGES
deleted file mode 100644
index 7832db3..0000000
--- a/CHANGES
+++ /dev/null
@@ -1,42 +0,0 @@
-$NEXT
-
-    [BUG FIXES]
-    * 'prepare_serializer_for_format' was clobbering the
-        default serializer. (RT#93478, reported by Pierre Vigier)
-
-0.07    2011-11-01
-
-    * Minor updates to fix warnings with Dancer 1.3080
-    * Fix POD
-    (Alexis Sukrieh)
-
-0.06   2011-05-28
-
-       [ TEST SUITE ]
-       * Skip test t/03_resource.t if Dancer is not >= 1.3059_01
-         A bug in Dancer::Test in previous versions prevent the test from 
passing.
-
-0.05    2011-03-04
-
-    [ BUG FIXES ]
-    * Fix the test suite with dancer_response
-    * Fix dependencies: Dancer 1.3014
-
-Version 0.04
-       [ Alexis Sukrieh ]
-       * Add all HTTP response status
-
-Version 0.03
-    [ Franck Cuny ]
-    * New keywords for ReST response status 
-         (status_ok, status_created, ...)
-
-Version 0.02
-       * 100% coverage
-       * fix a bug in 'resource' (order of route hander definition)
-
-Version 0.0001_01
-       * Support for prepare_serializer_for_format keyword
-         autoamtically set a serializer according to params->{format}
-       * Support for resource definition
-         When a resource is defined a set of routes are defined in a RESTful 
manner.
diff --git a/Changes b/Changes
new file mode 100644
index 0000000..b5e1aac
--- /dev/null
+++ b/Changes
@@ -0,0 +1,38 @@
+Revision history for {{$DIST}}
+
+{{$NEXT}}
+ [BUG FIXES]
+ - 'prepare_serializer_for_format' was clobbering the default serializer.
+   (RT#93478, reported by Pierre Vigier)
+
+0.07 2011-11-01
+ - Minor updates to fix warnings with Dancer 1.3080
+ - Fix POD (Alexis Sukrieh)
+
+0.06 2011-05-28
+ [TEST SUITE]
+ - Skip test t/03_resource.t if Dancer is not >= 1.3059_01 A bug in
+   Dancer::Test in previous versions prevent the test from passing.
+
+0.05 2011-03-04
+ [BUG FIXES]
+ - Fix the test suite with dancer_response
+ - Fix dependencies: Dancer 1.3014
+
+0.04 2010-12-22
+ - Add all HTTP response status (Alexis Sukrieh)
+
+0.03 2010-10-18
+ - New keywords for ReST response status  (status_ok, status_created, ...)
+   (Franck Cuny)
+
+0.02 2010-10-14
+ - 100% coverage
+ - fix a bug in 'resource' (order of route hander definition)
+
+0.0001_01 2010-05-06
+ - Support for prepare_serializer_for_format keyword autoamtically set a
+   serializer according to params->{format}
+ - Support for resource definition When a resource is defined a set of
+   routes are defined in a RESTful manner.
+
diff --git a/MANIFEST b/MANIFEST
index 529aaa4..0c0a2d9 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -1,9 +1,21 @@
-CHANGES
-lib/Dancer/Plugin/REST.pm
-Makefile.PL
-MANIFEST                       This list of files
+Build.PL
+CONTRIBUTORS
+Changes
+INSTALL
+LICENSE
+MANIFEST
+META.json
+META.yml
 README
+README.mkdn
+SIGNATURE
+lib/Dancer/Plugin/REST.pm
+t/00-compile.t
+t/000-report-versions-tiny.t
 t/01_base.t
 t/02_prepare_serializer_for_format.t
 t/03_resource.t
+t/04_helpers.t
 t/04_plugin_settings.t
+t/default-serializer.t
+xt/release/unused-vars.t
diff --git a/MANIFEST.SKIP b/MANIFEST.SKIP
index 7df8919..7ab08f8 100644
--- a/MANIFEST.SKIP
+++ b/MANIFEST.SKIP
@@ -1,3 +1,4 @@
+dist\.ini
 t\/logs\/.*log
 cover_db
 \.git
@@ -7,3 +8,4 @@ pm_to_blib
 ^Makefile$
 MANIFEST.bak
 MANIFEST.SKIP
+Dancer-Plugin-REST-.*
diff --git a/Makefile.PL b/Makefile.PL
deleted file mode 100644
index 8db95cc..0000000
--- a/Makefile.PL
+++ /dev/null
@@ -1,49 +0,0 @@
-use ExtUtils::MakeMaker;
-
-WriteMakefile1(
-    NAME         => 'Dancer::Plugin::REST',
-    ABSTRACT     => "REST plugin for Dancer",
-    LICENSE      => 'perl',
-    VERSION_FROM => 'lib/Dancer/Plugin/REST.pm',
-    
-    META_MERGE => {
-        resources => {
-            repository => 'http://github.com/sukria/Dancer-Plugin-REST',
-        },
-    },
-
-    BUILD_REQUIRES => {
-        'Test::More' => '0.87',
-    },
-
-    PREREQ_PM => {
-        'Dancer' => '1.3014',
-        'JSON'   => 0,
-    },
-
-    test => {TESTS => join( ' ', (glob( 't/*.t'), glob('t/*/*.t')))},
-);
-
-sub WriteMakefile1 {  #Written by Alexandr Ciornii, version 0.21. Added by 
eumm-upgrade.
-    my %params=@_;
-    my $eumm_version=$ExtUtils::MakeMaker::VERSION;
-    $eumm_version=eval $eumm_version;
-    die "EXTRA_META is deprecated" if exists $params{EXTRA_META};
-    die "License not specified" if not exists $params{LICENSE};
-    if ($params{BUILD_REQUIRES} and $eumm_version < 6.5503) {
-        #EUMM 6.5502 has problems with BUILD_REQUIRES
-        $params{PREREQ_PM}={ %{$params{PREREQ_PM} || {}} , 
%{$params{BUILD_REQUIRES}} };
-        delete $params{BUILD_REQUIRES};
-    }
-    delete $params{CONFIGURE_REQUIRES} if $eumm_version < 6.52;
-    delete $params{MIN_PERL_VERSION} if $eumm_version < 6.48;
-    delete $params{META_MERGE} if $eumm_version < 6.46;
-    delete $params{META_ADD} if $eumm_version < 6.46;
-    delete $params{LICENSE} if $eumm_version < 6.31;
-    delete $params{AUTHOR} if $] < 5.005;
-    delete $params{ABSTRACT_FROM} if $] < 5.005;
-    delete $params{BINARY_LOCATION} if $] < 5.005;
-
-    WriteMakefile(%params);
-}
-
diff --git a/dist.ini b/dist.ini
new file mode 100644
index 0000000..413b324
--- /dev/null
+++ b/dist.ini
@@ -0,0 +1,11 @@
+name    = Dancer-Plugin-REST
+author  = Alexis Sukrieh <suk...@sukria.net>
+author  = Franck Cuny <fran...@cpan.org>
+license = Perl_5
+copyright_holder = Alexis Sukrieh
+copyright_year   = 2010
+ 
+[@Filter]
+-bundle = @YANICK
+-remove = Covenant
+authority=cpan:SUKRIA
diff --git a/lib/Dancer/Plugin/REST.pm b/lib/Dancer/Plugin/REST.pm
index 0454404..1cd5757 100644
--- a/lib/Dancer/Plugin/REST.pm
+++ b/lib/Dancer/Plugin/REST.pm
@@ -1,4 +1,6 @@
 package Dancer::Plugin::REST;
+# ABSTRACT: A plugin for writing RESTful apps with Dancer
+
 use strict;
 use warnings;
 
@@ -6,9 +8,6 @@ use Carp 'croak';
 use Dancer ':syntax';
 use Dancer::Plugin;
 
-our $AUTHORITY = 'SUKRIA';
-our $VERSION   = '0.07';
-
 my $content_types = {
     json => 'application/json',
     yml  => 'text/x-yaml',
@@ -177,10 +176,6 @@ __END__
 
 =pod
 
-=head1 NAME
-
-Dancer::Plugin::REST - A plugin for writing RESTful apps with Dancer
-
 =head1 SYNOPSYS
 
     package MyWebService;

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libdancer-plugin-rest-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to